Navigraph Simlink sign-in

Dirtbike - ISP: Spectrum, State: CA


The common pattern we’ve found is that everyone affected are on Comcast, or ISPs that rely on Comcast in some way. It is not an issue with Navigraph infrastructure per se. Please contact your ISP’s support to report issues with connectivity against Amazon AWS which is our cloud provider.



Im talking from Brazil and two days ago i had that same issues.
From that day i still cant connect the Simlink with MSFS20.
I have installed several times and the problem persist, even included the program as exception in Norton 360.



Using image, please upload latest


Hi, Ian!
Tks for your help!
Log as below:


From the log file, it looks like there must be some configuration issue with Simlink.

Please follow the below steps to fix the issue,

In case of wrong proxy settings applied to Simlink.

  1. Close running Simlink and flight Simulators
  2. Open the Simlink configuration file .settings
    i. Press the Win+R key. (It will open a window like,

ii. Now type %appdata% and press the “OK” button.
iii. After opening the APPDATA folder, go to the <APPDATA>/Navigraph/charts folder. and open the .settings file into the notepad application

  1. Remove the [proxy] session from the .settings file and save it.
  2. Run the Simlink application and try to log in again.
  3. Done.

From the above points if the Simlink is not able to log in then there must be a configuration file corrupted. To fix this you need to reset the Simlink configuration by the below points,

  1. Close running Simlink and flight Simulators
  2. Open the Simlink configuration folder Navigraph from the APPDATA folder.
  3. Back up the Navigraph folder and delete it.
  4. Now start the Simlink application. It will create a new configuration folder Navigraph with default settings.
  5. Try to login into the Simlink application.
  6. Done :slight_smile:

Please let us know about the issue is fixed or not from the above points.


Ahir Vishal D.

Hi Ahir,

Neither of these fixes, or syncing the time worked. Any other ideas?



Hi aocbgoulart and John (Dirtbike),

Can you please advise if this issue is resolved.


1 Like

Hi Ian,

The issue was resolved.



Nope, not working. Please wait for authentication…

hello, and tried to perform the troubleshooting as you describe it but the problem continues. still won’t log in

Nope, not working. Please wait for authentication…

I follow these steps,but I can’t sign-in

I have followed all recommendations for installing both Navigraph and SImLink and FMS Manager. I’m on XPlane 12 with latest versions of all apps. X1000 FPL does not recognize the presence of my flight plan link. Be advised that Windows solutions do NOT work. Thanks in advance, Anthony PS. I have SimBrief installed as well. In the meantime, Navigraph is doing a helluva good job at creating routes, and I’m learning how to program them manually, stupid YouTube videos as to how to do that, notwithstanding. :smiley: :smiley:

I’m getting a similar issue to this, but after three different browsers and resetting the configuration file, I still get an issue where I login and simlink instantly displays the “you have been signed out” message.

1 Like

Same for me, yesterday simlink was working fine but know I can’t sign in.

" [2023-07-31 09:53:23] [] [INFORMATION] Configuration (Charts) file or folder is missing. Recreated!
[2023-07-31 09:53:26] [] [INFORMATION] OIDC_refresh_tokens_CALL
[2023-07-31 09:53:26] [] [INFORMATION] OIDC_start_hybrid_flow_CALL
[2023-07-31 09:53:26] [] [INFORMATION] OIDC_open_browser_auth_CALL[]
[2023-07-31 09:53:46] [] [INFORMATION] OIDC_refresh_tokens_CALL
[2023-07-31 09:53:46] [] [INFORMATION] OIDC_start_hybrid_flow_CALL
[2023-07-31 09:53:46] [] [INFORMATION] OIDC_open_browser_auth_CALL[]
[2023-07-31 09:53:56] [] [INFORMATION] OIDC_refresh_tokens_CALL
[2023-07-31 09:53:56] [] [INFORMATION] OIDC_start_hybrid_flow_CALL
[2023-07-31 09:53:56] [] [INFORMATION] OIDC_open_browser_auth_CALL[]
[2023-07-31 09:54:04] [] [INFORMATION] OIDC_authorization_code_flow[navigraph-traffic-desktop://oidc_sign_in_redirect/#code=cf0ec42ecc9a4d73e324cc1aa85f7973&id_token=eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiIsIng1dCI6IjA0X3JsNjNvV2ZBSVc3WEd4UWUzQzVEY3dkTSIsImtpZCI6IjA0X3JsNjNvV2ZBSVc3WEd4UWUzQzVEY3dkTSJ9.eyJpc3MiOiJodHRwczovL2lkZW50aXR5LmFwaS5uYXZpZ3JhcGguY29tIiwiYXVkIjoidHJhZmZpYy1kZXNrdG9wIiwiZXhwIjoxNjkwNzk4NDQ1LCJuYmYiOjE2OTA3OTcyNDUsIm5vbmNlIjoiVlNxWTNObFFnazJETTBjc3lVdUNha0RmdWpDQTd6QVQiLCJpYXQiOjE2OTA3OTcyNDUsImNfaGFzaCI6IjNqNi1XSURpSjdaeU1vcklsel90OXciLCJzaWQiOiI5ZGIxZmQzYzMzM2E5ZTkzNmI0NjRlZWI4NWMxNDBhNCIsInN1YiI6ImE2MWFjZmI5LTk5YTUtNGY5NS1iYjFlLWJlOTRhYmQwMzlkYiIsImF1dGhfdGltZSI6MTY5MDc5NzI0NCwiaWRwIjoibmF2aWdyYXBoIiwidXBkYXRlZF9hdCI6MTY5MDc5NjE4NiwicHJlZmVycmVkX3VzZXJuYW1lIjoiTGVvbGlvbklJSSIsInRvcyI6IjAiLCJhbXIiOlsicGFzc3dvcmQiXSwic3Vic2NyaXB0aW9ucyI6WyJmbXNkYXRhIiwiY2hhcnRzIl19.cRBnojc-xD__D6v_JRKge2uVUhgA2lAxlt1-2zqbSaRuZT1vEqUTjrMjFeGsS4LWbBymrQiobyTpFkBlOnPkjIppesJG-P_Y3sNG4Vg34TYZ3PKyek7cFJ6mq_VZBiQNB49NDgeSdq2PgQn5KI1eSeuPJvlrvBBPLy4r7i2XnDq_SKNFXV8o6VNVsY3bPUUCKO8_7otx_JoJFOh84L-LVg3Tt8KoGcBmc9cIWW9uLUCOtVohFS_7GjMLjaWCWqmGkdAnLVyCfIvf_r2bHaP-M6Z5D0jvdd7IkbvKQqV9_BA4vOb0MAzhnhwscohLYFMFv87MEOLceJi4-eBiSWr8Hg&scope=openid%20traffic%20userinfo%20offline_access%20charts&state=l1x4JEbqQZwfg1UY5MIhFvwMs9SIFxDn&session_state=uLukhJjouK8nbSS1VrnMHn45aAVDkM9mmKugJyKirNI.7f0f6a642cb3e4b50fd75ecff3635623]
[2023-07-31 09:54:05] [] [INFORMATION] OIDC_refresh_tokens_CALL[076cb6f78b58f5c981f2a27b3477f8c8]
[2023-07-31 09:54:09] [] [INFORMATION] OIDC_run_LastTokenGenrationTime_check[1690797249][1690797244][5][2]
[2023-07-31 09:54:09] [] [INFORMATION] OIDC_refresh_tokens_CALL[076cb6f78b58f5c981f2a27b3477f8c8]
[2023-07-31 09:54:09] [] [ERROR] OIDC_refresh_tokens ERROR:response json contains no ‘access_token’: {“error”:“invalid_grant”}
[2023-07-31 09:54:09] [] [ERROR] LoginController::login_oidcError[6][Your session has expired. Please sign in again.] "

Same Problem for me since 2 days. “You have been signed out”.
I have try all the above stuff, verified the Appdata propertues, tried to uninstalled completely Navigraph Charts, Simlink ans Navigraph HUB. I have also checked that the program is accepted in the firewall.
All reinstalled. After launching Charts, and the sim, it has worked for 20seconds before “You ve been signed out”. It has worked for 5 years, ans brutally stopped working !!!
You have changed the directories in which you installed it before. It was in Program Files, now it’s in Appdata/Roaming.
There is Navigraph stuff everywhere in my disk just like a pollution …
What did you changed recently ?


Please check this.

After cleanup please reinstall the Simlink Plugins.


Vishal Ahir

Hi Vishal,

Thank you for helping.

I tried that yesterday without any success, even after a restart.

And today, everything works again without any other thing. I DO NOT UNDERSTAND ….

Best Regards,



I tried all the possibles solutions but Simlink NOT works.
Login, Logout, Loging, Logout …

What can I do now?