Simlink won't let me sign in!

Hello all,

I cannot use the Moving Map anymore as Simlink won’t let me sign in to my account, at the same time, I’m already signed in on the Desktop app with Charts running and I’m using MSFS

I have been trying for the last three days or so to no avail. I followed all the instructions I could find on the Forum, i.e. uninstall from windows, Navigraph file delete from appdata etc. I even removed everything that has to do with Navigraph and re installed from scratch. I’m a fully paid up member with an Unlimited subscription, so far!

Please see some pics below:

Sign in page:
Sign In

Page not working:
Page Not Working

Error Page:

The below pic is what I get now, after uninstalled everything and reinstalled again, it’s only an information page explaining what to do, but this is all I see every time I run Simlink now! I’m never prompted to open Simlink as it is stating!!

Meanwhile, during all this, Simlink runs on the Taskbar! I also tried Quiting it, but when I run it again, it just go back on the Taskbar and the above repeats!

Is there anything I’m missing that I can get some help with please? Thanks in advance and sorry for the long Topic.

You are not alone. I have the same problem since yesterday. Reported but still waiting for an answer.

Hi Team,


Please try FAQ - Simlink Reset


Hi Ian,

Thanks for your reply. If I’m one of the team you’re referring to, please read my Post above

Just a gentle reminder, I’ve tried everything suggested in the FAQ’s you mentioned above!

I’d also like to add, that when I click on the Simlink icon running in the Taskbar, it just opens that dreaded window asking me to sign in (1st Pic in my previous post) it’s like it’s caught in some sort of a loop! Meanwhile Navigraph Charts won’t let me switch On Moving Maps and in the bottom it says in red: “Turn on Simlink on your simulator computer to use Moving Maps” which takes us back to square one!

I think, this happened to me after updating to the latest Navigraph Charts 8, which has been completely rewritten!

Well, for me it was always working fine before and I also notice that it’s not just me with this problem either!

I’ll be grateful if you’ll let me know about any updates re this problem. Thanks again.


As a test please try

  • Right mouse Run as administrator Simlink
  • Using a different default browser to login.


Thanks for your reply Ian.

I’m afraid I tried running many times with and without Admin rights, it makes no difference!

It won’t let me because, as I’m sure you know, Simlink doesn’t give you a choice what browser you want to use, it just opens in a window waiting for you to sign in, as seen in my first pic above, unless of course there’s a way to run Simlink on a preferred browser that I’m not aware of. In that case, I’ll be grateful if you or anyone could please show me how. Apparently it uses Microsoft Edge as the default browser, as seen below:

Sign in Scrn

As a test, download, install and in Windows, change your default browser to say Chrome.


Thanks again for your reply.

I do have the latest Chrome installed and up to date. On the Default Apps I found that the default browser was MS Edge as I mentioned already, so I changed it to Chrome. However, I hate to say it’s the same, I also tried Firefox but to no avail.

Chrome Default

Chrome Up2date

I’m getting frustrated now, not being able to use Moving Maps!!

Please check how many times I’ve been trying just today only, from my latest Log below! Hope you’ll be able to open it and maybe you’ll be able to spot something that might help!

simlink_2022-11-30.dlog (16.2 KB)


Thank you for sending us the log file, from the issue details it looks like some configuration issue.

Please follow these steps to fix it.


Vishal Ahir

Hi vishalahir,

Thanks for your steps to fix the issue, but please believe me, I tried those steps so many times and with all due respect, they’re no different from most of the other suggestions I already had.

However, the good news is that I sorted it out my way, and this is what I’ve done:

Once again, I uninstalled Navigraph Charts and Simlink with Windows Uninstaller for about the 3rd or 4th time. I also deleted every Navigraph file I had elsewhere. Then I did a registry clean, to make sure there’s nothing left from Navigraph. (Anyone thinking of altering the Registry file, please make sure you know what you’re doing and you’re familiar with this, as it could create serious problems in your Windows system), then I rebooted the PC. This time, I decided to install an old Simlink, I have some backed up in an old Navigraph folder, as I had a feeling that this must be a Simlink issue. I think the version was sometime in 2020 I’m not sure. When I installed it and loaded it, it showed that there’s a newer version and asked if I like to update it, so I decided to click yes.

After the update, I loaded it and surprise surprise, it worked as usual, the version it update to is I don’t know what version is this, but it’s working for me and I’m not prepared to change it or update it again, because this is the first flight I’ve done in over a week with Moving Maps and it works fine for me. Could you please advice what version is this, is it the latest?

Moving Map

Hope you can add this to your suggestions for others having the same problem with Moving Maps, as it will give me great pleasure to know that it might help them resolving their issue, assuming they’re having the same problem I had with Simlink of course! Thanks

Well done, glad it is resolved. You have the latest Simlink:


Thanks again for the info.
I wonder what version it was using before, I thought that when I updated to Navigraph 8, it installed the latest Simlink automatically, but then again I could be wrong! I can’t understand why I happen to install an old Simlink version and it informed me that there’s an update!

Nevertheless, it’s sorted now and thanks again Ian for trying to help anyway.

Best Regards.

1 Like

Hi Ian,
I’m having a similar issue notated above and I’ve tried all the steps outlined, however having the same issue when it loads up to google chrome, I’m getting the " didn’t send any data error. I am able to log into navigraph charts for desktop just fine, however simlink spits out this error. I’ve tried to do the uninstalls as well, use an older version and still getting the same issue.

Any help or suggestions you have is greatly appreciated.

simlink_2022-12-04.dlog (2.0 KB)

I had the same issues. Could not login. It had to do with time. My computer clock was off by 2 minutes!!! I set it to internet time and voila!! It works! Crazy but true!