Navigraph Charts will not open

After installing the Navigraph charts, the application does not start, so I cannot access the charts. A Java error message is also displayed (see screenshot). I urgently ask for information, what to do here to get access to the charts.
Thanks and best regards
J.Sieler


Hi,

We’re investigating.

Are you seeing this issue also if you run and install the Navdata Center app? https://download.navigraph.com/software/navigraph/windows/Navigraph%20Navdata%20Center%201.0.5.exe

Regards,

Stephen

Hello Stephen,

after installinmg the Navdata Center a white field with a blue "Sign in " botton appears and upon clicking this NOTHING else happens (which ist verystrange in my understanding).

Regards

Jochen

Hello Jochen! Welcome to the forum and sorry for the inconvenience.

Upon further investigation, we have established some probable causes of this issue. Let’s go through them one by one:


Network stability

Issue
The network is unstable. Sub-second disconnects that are not apparent when browsing cause critical communications with our servers to outright fail because the application is unable to reach the internet, alternatively being aborted “mid-flight”.

Proposed solution
Try to move to a more stable connection. If you’re on WiFi, see if it is possible to connect your computer using a network cable instead. If you’re already using a cable, make sure that you don’t have any loose connections anywhere.

In order to exclude connectivity issues, please attempt to use the “personal hotspot” feature of your smartphone or some other source of internet.


Firewall rules

Issue
The firewall (either as part of your computer’s built-in/third-party anti-virus or as part of your router/modem) is blocking the connection, resulting in communication between the application being forced to a standstill due to incorrectly set up rules.

Proposed solution
Configure your firewall to allow traffic associated with the Navigraph Charts and Navigraph Navdata Center.


DNS Issues

Issue
The DNS server is either not responding at all (incorrectly configured) or contains bad/outdated records, resulting in invalid communication between application and the internet.

Proposed solution
Try to (re)configure your DNS server, preferably using a reliable provider such as Google (8.8.8.8 and 8.8.4.4).


Proxies

Issue
Your internet connection is behind a proxy or is being intercepted. There are multiple reasons why this might be the case, here are a few examples:

  • You are using a work computer that has a proxy set up by default
  • You are using a proxy for personal/security reasons
  • Your anti-virus is intercepting all traffic to scan for malware
  • Your anti-virus/network security software has installed a self-signed certificate to encrypt insecure connections
  • You have tried to reverse-engineer our or someone else’s applications using reverse-proxy tools like Wireshark, Charles, and the BURP suite and then forgot to turn it off.
  • You have been infected with malware that is now actively deploying a MITM (Man-in-the-middle) attack towards you.

Proposed solutions

  • Disable any proxies
  • Investigate if turning off any anti-virus solves the issue
  • Disable any active reverse proxies
  • Investigate if your antivirus has any features related to scanning/intercepting network traffic. If it does, try to find related settings and turn them off temporarily to see if that resolves the issue.
  • Run virus scans for the whole system. Also, run a rootkit scanner such as this one.

If none of the above-proposed solutions work for you, please try installing our apps on another computer and see if the issue persists. If you are unable to reproduce the issue using another computer, you should probably consider reinstalling your OS.

I hope you find this information useful, and I hope that you find the root cause of your issue. Please advise if you have any more questions! Also, if you manage to find a solution then we would be very happy to hear about it so that we can recommend your solution to any other users who might have the same issue.

Kind Regards,
Malte

Dear Malte,

Thank you very much for your detailed information. Unfortunately, the individual proposals did not bring the desired success.

I now wonder if uninstalling and reinstalling Java Srcipt could solve the problem.

If not, I would have to delete the part of the charts from my subscription again. I would very much regret that, because I got to know Navigraph as an excellent company.

I would highly appreciate a short information.

With best regards,

Jochen Sieler

Hello again Jochen!

I’m sorry to hear that none of the above was found to be helpful in your case. As a last resort, I will contact you using a direct message with a few instructions. The reason for this is that the results might contain your credentials, which we obviously do not want you to share here.

I will update this thread if/when a solution is found.

Kind Regards,
Malte

As promised, here comes the update now that this issue has been resolved.

In this case, our apps were outright refusing to make the network communication necessary to sign in because of the presence of a self-signed certificate.

This certificate was installed by Kaspersky Internet Security in what I believe to be an attempt to encrypt insecure connections. In this case, from the perspective of our apps, this looked like an attempt to analyze encrypted network traffic to harvest credentials and in order to prevent this from happening, the apps (Both Charts and Navdata Center) disallowed any sensitive requests.

Solution

The solution was quite simple in the end. Just adjust the “Encrypted Connections Scanning” option to match the below and you should be good to go!