Navadata Center Issue


For the last several days I have not been able to open the Navdata Center. Whenever I try all I get is the sign in button. I click it, enter my details but it always fails. I have reinstalled x2 without success. I did reset Charts and the P3D Center with the same creds and they work fine. I’m on Firefox but since Charts uses the same login interface and works ok I don’t think it’s a Firefox issue.

Any ideas or help would be appreciated!


Good Morning,

Additional info, screenie below shows what I see after I sign in to the Data Center. Also shows successful sign in to Charts using the same interface. All I get is just a repeated sign in request.

Would appreciate any insight from the Navigraph team on this as I would like to update my MFS aircraft.

Thanks again,

Sorry to be a pain here but I am dead in the water. Can a mod please step in and help get this resolved?


It has been 8 days now since I asked for some help. I see some newer posts than mine that have been at least answered but no response from the team to my request.

Can someone from Navigraph please respond so that I can resolve this?



Sorry we have overread your report.

Would you mind switching default browser to Chrome, just to see if it helps? There are slightly different mechanisms in Charts and Navdata Center for signing in and it might make a difference.



Thanks for the reply. I don’t use Chrome, would Edge work? Also, until the last update Firefox had always worked just fine.

Ok, switched to Edge and it worked fine. Thank you.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.