Multiple addon sceneries, priorities and the "double runway" effect

Hi gents,
due the fact, that we don´t have really an answer what happened when we see the “double runway” effect, I have open a question in the internal MSFS “3rd Party forum”. I have tried now to reproduce this effect and I can.

Test-scenario:
I have used the sample-airport (MYNN) from the SDK and has created two packages - “ProjectOne” and “ProjectTwo”. Both packages are equal, but in “ProjectTwo” I have changed the runway-coordinates slightly to see what happened. The sims starts and I see both packages at the end in the content.xml file (“ProjectOne” is directly above “ProjectTwo”).
image

… the result is the “double runway” effect:
image
“ProjectTwo” overwrite partly “ProjectOne” but as an example not the runways

… when I remove “ProjectTwo”, I see only “ProjectOne” and this is a clean single runway:
image

This has nothing todo with our data. This happened also, when I remove our data but this is very easy reproduce able with the sample-airport in the SDK. I have now asked the question to ASOBO, how that can fixed it and I hope I get any answer …

Just for info
Richard

… when I remove the p

From what I understand, this only happens for airports that were not originally part of the Sim, and where Navigraph has to install at least a runway. Wouldn’t it be possible to have the user chose if or for which airports he wants runways in the Navigraph installer?

Correct - this happens only on airports, which were not included in the default data. I´m currently testing since nearly a week, to find out, why this happened and to find a way to reproduce it for ASOBO. It´s like a puzzle and very frustrating but I´m 100% sure, that there is something wrong in the logic of the sim, but I don´t know what to explain it enough.

The option to offer multiple downloads or select airports is no option. It´s very sad, that no direct partners get so less support from ASOBO. Several months after the official release, and no real step forward of the SDK, nor a documentation. We can´t fix all bad coding or logic of ASOBO, sorry.

Cheers,
Richard

My issue was referring to gravity EDDS. Is there anything the guys who created the scenery could do to fix that? The scenery this group has created is just marvellous.

Hi,
thanks for coming back with this and I guess, I have some good news for you:

We will release a new revision 15 in the next couple of hours, where we had made some internal changes and fixes to solve such issues. Here a screenshot with the new revision:

Indeed the scenery looks great but it´s not clear for me, why they had added waypoint and terminal procedures - because they must maintain this kind of information every 28 days. That´s exactly the reason, why sceneries and navdata should be splitted. And of course, it´s a support question also - because I assume, that when someone identified any issue in the procedures, he/she will report it here but we are not the provider …

That´s not the best way in my eyes. Such data has nothing todo in a scenery … but that´s my personal view.

Cheers,
Richard

Hello Richard,

thank you for your support. If every developer worked that way …
It is good to hear that things will be fixed and I will inform the gravity team about this thread about separating nav data from scenery. Again, many thanks,

Matthias

Hi,

I talked to the group on their discord and they say they had to enter all the nav data manually because MSFS did not have anything for EDDS as it did not exist in the vanilla version of the sim. Seems they are now considering splitting their scenery into two parts - scenery and navdata for non-navigraph users.
And again, I cannot stress this enough, thank you for your great support.

Best,

Matthias

1 Like

Hallo Matthias,
excellent, a very good idea :+1: … thank you very much for the update. Also, thank you very much for your kind words. We are also not perfect and we learn also with the sim, with every line of code and of course thru you, our customer … which is not an unimportant part in this business.

Thank you very much & Fröhliche Weihnachten :christmas_tree:
Richard

Hello,

just installed the revision, and, fair enought, it is only one runway. But what a runway that is…

I don´t know

Cheers,
Richard

@froemmelm Is that supposed to be EDDS from Gravity? Can’t 100% tell from your screenshots as there are quite some differences (can’t see the taxiway e.g.). Because I followed the instructions in FAQ - Double scenery elements and it looks fine to me:


This is my Context.xml after the instructions:
Content.xml (4.6 KB)

@NAVData just for clarification, in Release notes - AIRAC Cycle 2013 - revision 5 you write if the freeware scenery “Aerosoft Paderborn” is installed, this package MUST BE on the first line in the content.xml file. As you can see in my Context.xml it’s not on the top after following the instruction, but I also have Paderborn installed from the Aerosoft installer inside the Community folder and not via the Marketplace in Official/OneStore, so I’m not sure if it should still go on top of all the internal packages. I haven’t noticed any problems yet.

Hi Jan,
haven´t moved my Paderborn scenery from the “Official/OneStore” - but interesting idea.

The strange thing is, when I delete my content.xml file and when I let the sim create this file, the Aerosoft Paderborn package is always on the top. Also, there is a freeware scenery RPUO (https://flightsim.to/file/4564/basco-airport-rpuo). I was in contact with this developer and he shared the source file - all looks good in his file, but the strange thing was, that when the Aerosoft Paderborn package was AFTER our package - this scenery shows double runways or only our runway, … so it was completely mess.

When the Aerosoft Paderborn is above our package, all is good and the scenery looks like it should. It would be great, when you can try to install the scenery on your system to see what happened.

Also, have you deleted the content.xml file or only manually re-ordered?

Thank you,
Richard

PS: I have changed the release notes slightly now … :roll_eyes:

Yes, it is gravity’s EDDS. All taxiways and aprons are gone but the buildings - like the newly modeled terminal, DHL and Tower are still there. I suppose there is something weird about caching going on.

Have you done this (point #2):

Cheers,
Richard

FINALLY! point#2 did the trick. Up until now I had manually edited the content.xml file to make sure the order is correct. All seems to be fine now - the holidays can finally come.
Thank you all, and a merry christmas to everyone. :santa::christmas_tree:

Woho … Christmas can come :+1: :christmas_tree: - Thanks for the feedback …
Richard

I’m not sure if that’s possible, as they are from different sources (Official/Onestore from the ingame store, Community from external Aerosoft installer) there might be differences (e.g. the one from the ingame store might be fsarchive-encrypted).

I have a problem with multiple airports in northern Quebec
Lots dont exist stock ingame, and I use those

I had double runways pretty much everywhere.
Downloaded the new update today, and had to manually set Navigraph’s priority to the bottom (did the procedure on the FAQ)

Now I dont have double runways, but grass is over most gravel runways, and I dont see ramps/taxiway anymore

I can speak directly to the maker of those airports if you find something that would help

*CYPX & CYPH are good exemples
Thx!

Hi,
but there is no instruction somewhere, that you should edit anything manually …

image

Please do exactly these steps …

I´m pretty sure, that the addon-scenery designer hadn´t set #1 from the FAQ. You should forward the guys there this part.

Cheers,
Richard