Denied Access

Hello,In the last 3 days I have subscribed an account with Navigraph with a Unlimited Package. I have downloaded all the relevent downloads for my
X-Plane 11 Sim. I just went to open the Navigraph Hub and it Denies Access saying i need to be an Active Navigraph Subscription, which I thought I was. +??? Anyone with the solution would be grateful.2023-10-13T13:00:00Z

could it be, that you use two accounts? Had you a subscription before, or had you created an account before?


Hi, thanks for reply, but no, only one account and all other downloads are working ok.
Maybe I need to uninstall Navigraph Hub and then start again and download and install it again.
The problem is it will not let me in to Navigraph Hub to see what might be the problem with accounts or payments.
What do you think.


Have the same issue. One day it works another does not.
Screen shots attached.

Hi @MRSIMER52 and @MrFlyOZ !

As Richard already mentioned, the two likely causes of this issue are:

  • You do not have an active subscription
  • You have two accounts, one with a subscription and one without, and you signed into the wrong one

In this case, I can see that both of you have active subscriptions on the accounts that you used to post in this forum. I have enabled additional logging on these accounts, please try to sign in again and I’ll see if I can catch anything!

Also, see this post for instructions on how to verify that you are signing into the correct account:

Kind Regards,

I’ve solved this issue after reinstall of the software. So this is bug for sure.
As I said it works right until the moment it does not.

Then I reinstall it again.

You will not get access denied without cause. It means that we successfully signed you in, but that the server did not see any active subscription for the signed-in user. A reinstall should not affect this, and we have never heard of a case where the subscription has been temporarily missing like you describe.

We have, however, seen many cases where users have accidentally used a different account, which would absolutely yield that message!

That said, I can verify what is happening the next time it occurs! Just let us know, and I will check the logs to see if I can see something!

Kind Regards,

But it affects! Sooo… It is a bug!

I have only one account. My subscription is current. I’m telling you how I resolved this issue.
You tell me I wrong.

Now you have another case. Check this issue!
Do you need video proof?

I am not telling you that you are wrong. I am stating that we have had identical symptoms numerous times and that it has so far always been down to accounts being mixed up. It would not have been the first time that someone was absolutely sure that they did not have two accounts and that still being the case in the end. I just wanted to make sure that this was not the case in this instance! I am not looking to prove you wrong.

I mentioned before that we are checking it, see these two sentences:

Unfortunately, that is all we can do now since the issue is not reproducible by either you or us. If you encounter this issue again, please let us know as quickly as possible and we’ll try to see if we can find anything in the logs!

Kind Regards,

Just reproduced it again.

Take a look at


  1. Sign out button does not work!
  2. Installer failed on the first attempt. Probably not. But there was not any indication of success. On second attempt Navigraph Hub started.

Thanks! Unfortunately, it seems like we never get any logs in this scenario. However, this might be related to something that is completely external to the Hub itself (even affecting other services like SimBrief), which is currently under investigation!

I’ll let you know when I have an update!

Kind Regards,

Thanks for your ongoing help.
Just a few things to tell you about my situation, Only have one account with my email,
which Navigraph .com accepted and is paid up to date, navigraph charts is up and running OK, simlink is OK,
navigraph FMS data is OK, then to open Navigraph Hub shows Denied Access to an active account.

I have noted in Your Account (devices) shows I am signed into devices and apps the following, and there are several times all the above apps are showing here, SO iam going to sign out of all the early ones and leave one of each in this section (what are your thoughts on this).

On my new computer I have X-Plane11 placed in Drive D (Storage) and all Navigraph apps were downloaded to Drive C on computer, would this cause a problem?

Finally IF Navigraph has 2 accounts outstanding, how do i find this out, because as I said before, I went into Navigraph and it shows only one account.

One more thing is with Avitab, they say it is possible to obtain charts this with this plug-in and to see them in the Airport app, what is the Airport app, it does not show in my Avitab in cockpit.

thanks again
We struggle on

We’re looking into ways to get more insights into both of your situations. It is not a general problem, and we cannot reproduce it ourselves, so we’ll need to collect more information from you!

This will require some changes to the logging capabilities of the Hub. We will make them as soon as we can, and I will let you know when I have updates!

This is a separate question. You might be interested in this thread:

Kind Regards,

Hi Some good news. Reference Navigraph Hub…I went in Your Account in Navigraph…scroll down to Devices… and found a lot of Navigraph Hub in there, so signed out of them. Went back to Navigraph Hub and signed in and it worked. Now all i have to work on is getting Navigraph Charts into Avitab, and will look into your advice.
thanks again

I cannot gain access to navigraph hub
The only change to account was a different payment method last month

Hi! We’re still puzzled as to what might have caused this for any of you, but we will be releasing an updated version of the Hub soon which could improve things while also making it possible for us to investigate the issues further!

Kind Regards,

Hi guys please download this version which will log what is going on :slight_smile:

Kind regards,


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.