Simbrief loading problem

Hi to all , from today i cant load simbrief page. It takes eternetyx to main page, but subpages simply arent loading at all


Had the same problem, loading, loading, loading, nothing more happens

I have the same problem. I wasted the whole time in the morning till now trying to solve it. but nothing helps. any ideas why? It also impacts the simbrief loading in the aircraft (e.g. Fenix A320)

I’ve also noticed there was yesterday an update, version 2.14.2:
“Fixed layout bugs in the latest Chromium and Webkit-based browsers.”

Could it be the source of the issue?

I have the same problem

Same for me. Loading but nothing happens.

Now it worked for me from itself…pls confirm.

Hi Team,

SimBrief is working fine for us. It might have been a temporary internet issue.
Please confirm if resolved.


I have same problem on my iPad2, but no issues on PC. Any idea?

Hi, the SimBrief interface requires iOS version 12.4 or later. The iPad 2 can only run up to iOS 9.3.6, so I suspect it isn’t compatible unfortunately.

Best regards,

simbrief loading problem for more than two days, it only work if I VPN. now is this country specific or the webhost problem

1 Like

Same issue here, the webpage takes very long time to load, prone to server timeout. I also i run a TFDi PACX connected to simbrief, and it is having a difficult time to pull the flight data

1 Like