Windows Error R6034

Dear All,
Every time when I opened this Navigraph FMS Data Manager, I receive this information show C+++ Runtime Error R6034

. I already installed it again but doesn’t work. Would you mind to give some sort of solution.
By the way, after I click on the OK button the application starts normally. It starts to happen when I did the application update. I use windows on my computer.
Best regards.
Alexandre Markovits

we are still working on it!

Hi Alexandre,
A few others have reported this as well, so you are not alone. Hopefully Richard and Navigraph can find a solution or I expect a flood of complaints when thousands of users launch FMS Data Manager for the first time in a month when the next AIRAC is released…
Any updates, Richard? Thanks!
Best Regards,

Thanks again. I will be waiting for the solution.
My best regards
Alexandre Markovits

Hi gents,
as I have written - I´m still working on it and we have a version, where we have binded the C++ libraries directly with the application, so that we don´t need any reference from somewhere else. With this version, we can be sure, that our application uses really the necessary libraries … but, we are not “alone”, we use Qt as underlying framework and this framework needs also the runtime libraries - means binding the files to our application is one thing, but won´t work with an external framework.

The good point is (for us):
In nearly 99.9% the FMS Data Manager is working for the customer, without any error (also after the latest update). We have currently “only” four customer, with this error, so handle able at the moment and also for new cycles. This is not a general common issue in the FMS Data Manager, it´s specific on these four customer.

Till now, I haven´t found any customer, who accept a remote-session, that I can directly look on the system. Therefore it´s a little bit hard and very time-consuming to find out, which application on the system, needs which libraries.

To be sure, that you have at least our recommend library installed, please follow the next steps exactly:

  1. close the FMS Data Manager
  2. Win+R and input appwiz.cpl
  3. now look for the line “Microsoft Visual C++ 2015-2019 Redistributable (x86)…” Version 14.28.29914.0
  4. click on “uninstall”
  5. Download the MSVC++ 2015-2019 Redistributable (x86) package from here and install it again
  6. after a successfully installation, reboot your system (not really necessary but I would do it)
  7. start the FMS Data Manager again

These 7 steps are very important for all upcoming versions and also for me, for the support. Without a correct installation of this redist-package (in the correct version), the application will not be working correctly.

Please let me know, the result …
Thank you - will go ahead with looking for a solution

Hi Richard,

Didn’t workout. Check the attachment.

Cheers Alexandre Markovits

Enviado do Email para Windows 10

Hi Alexandre,
sorry, bad communication from my side. This shouldn´t be the final solution :slight_smile: … it´s only to be sure, that we use all the same level and the same version to avoid some other side-step issues.

But I have one request:
Can you upload the latest log-file here please, after you press the OK button?
You find it here %ProgramData%\Navigraph\FMSClient\logs

Thanks :wink:

One additional test for all, to see if any other 3rd party application produce the mess of the runtime-files:

  1. Win+R and input msconfig

  2. the System-Configuration window will be open → select the “Services” tab (red circle)

  3. click “Hide all Microsoft services” (green circle)

  4. click “Disable all” (blue circle)

  5. goto the “General” tab (red circle) → click on “Selective startup” (yellow circle)

  6. un-click “Load startup items” (brown circle)

  7. press “Apply or OK” and reboot your machine

After that process, try to start the FMS Data Manager again and look, if you still get the error-message. If yes, you can revert every step again … when no, you know that any other application-service produce this error.


Sorry Richard,
Would you mind to be more specific about how should I upload the latest log-file?

Oh yes, of course …
Copy & paste the %ProgramData%\Navigraph\FMSClient\logs into your explorer.

Then you see a kind of this files

Take the latest file and drag & drop it here in the forum into a new message/reply. Thats it … :wink:

Hi Richard, did not work!
Still the same problem.

Please can you upload the latest log file as requested?

Any chance that we can do a remote session, that I can look directly on your system to solve this? It is nearly impossible at the moment to find where the issue is on your system, and it´s an issue on your system, sorry to say.

Thank you & cheers,

Hi Richard, I’m excited to help out with this but I may not be able to attempt your instructions until late tonight (4/15 UTC-7 Arizona, USA). Thanks for all your efforts!

Best Regards,

Hi Richard,
So i have updated the verison of MSVC++ 2015-2019 Redistributable (x86) on my machine. I was running version 14.28.29325.2 but after the update I have 14.28.29914.0.
I still have the same R6034 error upon lauching FMS Data Manager but as I mentioned earlier it still appears to run fine after clicking OK. As requested, attached is my log file from the latest launch.

20210417-223635.log (12.6 KB)

Hi Richard,
My apologies for this delay, but I am away from my computer at this moment because of my work. Give me some time and I will replay to you ASAP.
My best regards
Alexandre Markovits

Hi Richard,
Tried eliminating the third parties as you instructed and the R6034 error remains. So weird that FMS Data Manager worked so well for me until this last update. I will be interested to see if it still works despite this error when I go to update my apps with the next AIRAC release. Should be soon, right?
Thanks for all your efforts in trying to solve this problem!
Best Regards,

Hi guys,

The log from Scott looks absolute normal and the application works on his machine as expected. This R6034 is really strange because as I wrote, it happens only on a handful of installations. What I have figured out (thanks Mr. Google), it´s in most cases an issue on the user machines (such as corrupt files, wrong path-setting environment, bad registry keys, or similar). I have never seen this error nor can I reproduce it on any of my different virtual machines.

The log from Scott shows me only, that the FDM starts as expected so this error has nothing to do with our code. It´s more before the FDM starts when the core-libraries for the application are being loaded. I hope, someone can accept a remote-session, so that we can look at one of these system with a process-explorer, to see what is happening at the beginning during the loading of the FDM.

That explains why the FDM works as it should after clicking ok … it´s not a coding issue, it´s an issue during loading the core-libraries/components which are installed in the OS.


Here it is. I just uploaded the file. Richards
Best Regards
20210419-175614.log (16.8 KB)

Hi Richard,
What does not make sense to me is why this issue only came up after FDM was updated? Could it have something to do with code that calls these core- libraries? Could it be related to the particular version of windows, windows update, or dll? Weren’t these same core- libraries called without issue prior to the update on these same machines? What changed? Why does FDM run ok in spite of the error message if there was something actually wrong with a core-library? As far as corrupt system files are concerned windows system file checker found no issues on my machine. I believe another user found the error to persist even after stopping windows services. I would seem that we have explored all of the “Mr. Google” issues known to trigger this error message which in the end does not prevent FDM to run normally. How strange. I am not surprised that the error is not present on your virtual machines as they cannot truly represent the content of actual machines manifesting this issue. I believe that the focus needs to be on what changed in your FDM update!

I checked my window as well and I did not find any file corrupted so far. Very strange.