Navigraph FMS Data Manager crashes when I try to update AIRAC

Whenever I try to download a new AIRAC cycle on any addon, the FMS Data Manager crashes to Desktop. I tried reinstalling, no change. i deleted all associations, no change.
Version 1.8.5.1105 running on Windows 10

Hello Bernhard! Welcome to the new forum.

Please make sure that you have the latest Visual C++ from Microsoft installed. See FAQ - FMS Error "api-ms-win-ctr-runtime-l1-1-0.dll" or "(0xc000007b)" for links.

If the issue persists, I need logs from the application to assist you further. You can find them at C:\ProgramData\Navigraph\FMSClient\logs and then attach them to your next post!

Regards,
Malte

Hi Malte,
Thank you for your prompt response. I have the latest Runtimes but installed the runtimes in the link you provided anyway (both, 32 and 64-bit). Sadly, no change. So I tried uninstalling and reinstalling them, also no change. A reboot also changed nothing.

I don’t have the directory you mentioned. The Navigraph FMS Data Manager is installed in “C:\Program Files (x86)\Navigraph\FMS Data Manager” and there is no logs folder in there. I can, however, provide the Minidumps for each crash if that helps.

How can I proceed?

Thank you,
Bernhard

Sorry, I should have been more clear. The C:\ProgramData folder is usually hidden, to find it you either have to enter the path directly into the Windows Explorer path field, or enable the “Hidden items” options in the View tab (see reference below)

Regarding the minidumps, sure! Please send anything that might help with tracking down the issue!

Cheers,
Malte

You can actually disregard my first post, as I probably read it a tad to fast. Your issue, as I understand it now, is that the application crashes as soon as you try to update the AIRAC data.

If this is the case, then the logs will be of great value when looking for a solution as I am not able to reproduce the issue on my system.

Regards,
Malte

20210108-103730.log (11.1 KB)
I just found it. Thanks for your help!

Are you positive that this log is from a session where the app crashed? The last six numbers of the filename represent the time at which the report was generated.

Regards,
Malte

Yes, I’m sure. The report is from my last attempt (today, 10:37:30 German time). I can also Provide three more, one of which I just triggered.20210108-150419.log (11.1 KB) 20210108-102956.log (11.1 KB) [20210108-102715.log

20210108-102715.log (11.1 KB)
…and the third one. I can only attach two logs per posting. That’s all of the logs i have.

However, I can also provide MInidumps for every crash since the logs don’t include helpful information.

Thank you.

Please do, that would be helpful and appreciated!

Of course, you can download 7 Minidumps (zip compressed) here: https://1drv.ms/u/s!AuJinypBD16XjeNYY4VrcURZs5jykg?e=4iXLc5 They are far too big to attach here.

Hello again Bernhard! Sorry for the late reply.

Can you confirm that you have a file called ssleay32.dll in your FMS Data Manager folder located at C:\Program Files (x86)\Navigraph\FMS Data Manager?

Thank you for your patience!

Regards,
Malte

I’m very sorry, I was admitted to the hospital during the weekend and do not have access to my computer. I’ll let you know as soon as I’m home again. I promise to remember it will only be a few days.

1 Like

No need to be sorry! I wish you all the best :slight_smile:

Just reply to my latest post in this thread once you’re back to make sure that I get a notification!

Cheers,
Malte

Hello Malte,
It took a bit longer, I had to undergo surgery. That’s why it took so long. I’m back at my PC now and do NOT have that file in the folder you mentioned… Also, I do not have a file with that name anywhre else on the PC.

Hello again! I hope everything went well!

That would be a probable cause for your issue. That file is responsible for making secure connections from your application to us. Please follow the below steps:

  1. Download the Visual C++ Redistributable for Visual Studio 2015
  2. Close FMS Data Manager
  3. Install the downloaded redistributable (Select “Repair” if installation already exists)
  4. Start FMS Data Manager and see if the issue persists.

Regards,
Malte

Hello!
I’m sorry but the issue persists. I downloaded and installed the Redistributable that you linked in your answer. In order to do that, I had to uninstall the 2015-2019 redistributables you linked in your first answer because they are newer and I cannot install the older 2015 redistributable over them. However, it works neither with the 2015-2019 nor with the 2015 redistributable.20210118-141302.log (11.0 KB)
Also, I attached the Logfile from today’s crash (with the redistributable you linked in your latest answer)

Also, I’d like to point out that installing a redistributable doesn’t install a .dll in the program folder. So, the file ssleay32.dll is still missing. Reinstalling after installing the redistirbutable didn’t change this. Also, copying over the .dll from another application on my computer didn’t change anything (I deleted the copied .dll in the meantime).