Switching rendering mode (2D/VR) results in sign-out

The last flights I’ve been doing, I’ve been asked to sign in every single time after switching to VR. Which is a true pain since you can’t access/see your browser in VR. At least not without any extra tools such as some form of virtual desktop.

At the same time, you can’t switch to 2D mode and sign in from there but you need to stay in VR. Looks to me like the Navigraph window in 2D and VR are not linked as far as being signed in.

So, whenever this happens, you need to press the sign in button or whatever it’s called, then take your VR headset off but remain in VR mode in MSFS. Then ALT+TAB to the browser waiting for your confirmation to allow signing in and only after this, you can put your VR headset on again and actually see the Navigraph charts.

Navigraph team, please look into this issue and stop this constant prompting to sign in.

With many thanks in advance.

Hi,

We’ll keep investigating the issues after the holidays. Right now the team are off for a break. But please keep posting reports and we’ll look into them when we get back.

Kind regards,

Stephen

1 Like

Fully understand you guys need a well deserved break like everyone else!

Once you’re back in business, I hope you’ll be able to figure out what is causing these endless loops of having to sign in constantly. Many times such on my last flight, several times during the same flight. After having switched from VR to pancake mode and later on back to VR again.

Until then, enjoy your time off and happy new year 2023!

Mines been fine regarding the signing in issue fir a while but my flight this evening needed signing in once more, i thought the problem was fixed.

Was just about to ask if others see this constant sign in issue as well or if it’s something went south on my side.

Looks I’m not alone which is good to know.

I do get the sign in problem, but it’s intermittent. Most sessions it doesn’t happen, but the other day I had it three times. No obvious trigger for it.

Got it.

Over here, it’s been crazy for the last week or so to a degree where I almost consider stop using the Navigraph in-game panel. Simply because it becomes too much of a pain having to take your VR glasses off in order to be able to sign in whenever you switched from 2D to VR mode.

As mentioned, over here it happens every time lately. Where before, it was as you describe, more random.

@WebMaximus Thanks for the feedback.

Can you correlate the issue with any actions in particular? As in pressing a certain button in the panel, turning on moving maps, etc.? Any particular interval? We need as much data as possible in order to track this down.

It’s whenever I’ve been in 2D mode and switch back to VR I’m forced to sign in again.

Once signed it, all is good until I switch back to 2D and then when switching back to VR, same thing again.

Ah! That narrows it down a lot, thank you.

Unfortunately, I am not sure that there is anything we can do here. The simulator seems to get rid of the details that we need in order to keep you signed in when switching contexts like that. We’ll still investigate of course, but if that is the case then there is unfortunately nothing we can do without Asobo making changes to the simulator which is… unlikely.

Let’s hope that we can find yet another hacky workaround!

Will try version 1.3 and see if it’s the same thing. As I recall it, I didn’t see this issue before using the beta.

If the problem is on MSFS side, wouldn’t it be the same when using version 1.3 of the in game panel?

Yes, you are right. If it works in 1.3 it should be possible in the new version as well - but conceptually we are not doing anything different, so if it works in 1.3 then that is a surprise really…

In that case, it might be down to the new version being more complex and therefore loading slower which in turn could throw off the timings somehow - which also makes it hard to reproduce. I don’t have a VR setup myself and cannot try this out until the team is back from the holidays, unfortunately.

Got it.

Will do some testing using version 1.3 and will report back.

So I’ve now tried version 1.3 and can confirm, no need to constantly sign in whenever switching back to VR from having been in 2D mode.

So whatever is causing it, there indeed is a difference in this regard between version 1.3 and the new beta version.

Thanks for looking into it! As mentioned, I’ll do some further investigations when the team is back - apologies for the inconvenience in the meantime.

1 Like

Thanks and fully understand many of you guys are off from work these days but will keep my fingers crossed you’ll be able to figure it out in a not too distant future.

Right now with the two options I have using the old version and missing all good stuff in the new version or using the new version and constantly having to sign in, neither one is very tempting.

Moved some posts from the main beta thread to this topic in order to stay organized, apologies for any inconvenience this might cause!

We’ll track this issue in this thread from now on.

Actually, I’m happy to tell you I just performed a flight and for the first time in a long time, I wasn’t asked to sign in constantly like I have been lately.

Not sure if you did anything that solved the issue or if it’s more how exactly I use things over at my side. What I mean and think could possibly affect things are:

  • is the Navigraph in-game panel open in 2D mode when switching to VR
  • when switching back to 2D from VR, is the in-game panel open in VR or closed or hidden
  • etc

So many variables here to keep track of. Making it a bit hard to fully understand what is going wrong and when and for what reason.

Will do more testing and if I find out anything else of interest, I’ll let you know.

1 Like

Very right indeed - which makes it harder to troubleshoot for us!


Sounds like two reasonable points of interest at least, judging by this thread!


Thank you for participating in the beta everyone, your feedback and insights are much appreciated! The more data points we get regarding this issue the better.

After a few days without constant sign in requests, today the problem was back. Where I had to sign in again over and over again. Both in 2D and VR mode.