SIMLINK no connection

Hello dear support team,

I’ve tried everything I’ve read on the forums. Virus scanner and firewall disabled. But: in navigraph (tablet or PC) no connection to Simlink.(Could not connect to simulator, Simlink needs to be running.) This problem occurred after the last update. I am sending you my log file. But I have no idea what it could be.

Please help me. My system WIN10 with P3dv5.3

Greetings

M. Schröder

Hi…,

Welcome.

Please try Cannot sign in in Simlink or Charts, online charts work - #2 by vishalahir and SImLink disconnecting during flight - #6 by vishalahir

Cheers
Ian

Hello,
I’ve already tried all of that. Sign in also works, but SIMLINK doesn’t show a server and doesn’t find a simulator either.

Hi,

After Sign In to the Simlink application, make sure you install Simlink Plugins to Flight Simulator. And In the case of MSFS, you do not need to install Simlink Plugins.

To check Simlink plugins are installed correctly, just start the Flight Simulator and the Simlink application will automatically start with the Simulator.

Please feel free to inform us about the issue.

TR,

Vishal Ahir
Navigraph

I’ve done it all x times. It just doesn’t work.
Have the p3dv5.3 everything worked before the update.

Hi,

If you have an issue with Simlink not connecting with the Simulator then please check Simlink Plugins are installed correctly on the right installed Flight Simulator.

To verify Simlink Plugins installed on the correct Flight Simulator path,

  1. Open Simlink Application.
  2. Open the Navigraph Simlink Plugin Settings window.
    image
  3. In the Plugin Settings window check whether all auto-detected Simulator path is correct or not.

    Note: Above SImulator display path is just for reference, in you system path must be where you install Flight Simulator
  4. If any Simulator path is wrong then please Repair / Reinstall that Flight Simulator. or If you are more technical sound then you can correct the Path from the Windows Registry.
  5. Or you can manually set the Simulator path by clicking on this button
    image
  6. After verifying and correctly installing Simlink Plugins, to check whether Simlink is connected with Flight Simulator or not then just exit the Simlink application and start Flight Simulator than Simlink application with Automatically start with the Flight Simulator.

(For MSFS 2020 you do not need to install any plugins just make sure the Simlink application is running before MSFS 2020 runs)

  1. Done :slight_smile:

Please feel free to inform us if you have any issues with Navigraph Products.

TR,

Vishal Ahir
Navigraph

Many thanks to Vishal Ahir
I was already despairing but the support is just great. Had almost an hour to find the error on my system. Thanks again a thousand times.
Greetings from Oldenburg (Lower Saxony, Germany)

Hi, used simlink a few days ago, working fine. Did an upgrade, hasn’t worked since. I have tried all the above listed solutions.

First Also please provide information as per FAQ - Information requested when posting an issue

Please be specific about hasn’t worked since, What are you trying, what error messages, is it a login issue etc, so we can replicate. Have you restarted machine?

Screenshots help using Guide to posting Screenshots

Cheers
Ian