Simlink annot connect to flight simulator


I am new to Navigraph and have just installed charts and simlink.

It seems I have the perennial problem of simlink not connecting to the simulator. I have read many of the posts on the topic and have tried many of the solutions but to no avail. I have followed the steps described by Ian - uninstalled all navigraph software, deleted remaining folders, re-installed navigraph charts and simlink with my AV and firewall (Norton 360) disabled, modified the environmental variables as suggested by Vishalahir,
started simlink then started MSFS2020, loaded a simbrief flight plan but when I press the red arrow on the route chart it tells me ‘cannot connect to simulator’. Have also checked simlink is still running on my machine at that time.
I have tried all the above several times, restarted the computer etc and still the same result. I have also tried running the programs with my firewall turned off in case it was blocking connection to the Navigraph server, but still the same result.
I am running windows 10pro v20H2, OS 64x build 19042.1526
Navigraph charts v 7.7.1
Simlink v1.1.25.0120
How do you open the Simlink status screen shown in the various posts? If I left click on the status tray simlink icon it opens the Navigraph Icon splash screen asking me to sign in (which I already am) and then it tries to reinstall charts (which I cancel). If I right click it takes me to the plug in screen and nothing else, but I don’t need plug-ins for MSFS2020.
Here is the simlink dlog
simlink_2022-03-13.dlog (1.2 KB)

Charts is working fine both on the PC and in MSFS2020, but no moving map. I am flying the stable version of the FBW320NX but I guess this would have no effect on the simulator not connecting to simlink.


1 Like


For Moving Map functionality work, you need to make sure below points,

  1. Make sure the Navigraph Simlink Application is running.
  2. If you do not login into the Navigraph Simlink application then you have to login into the Navigraph Simlink with Navigraph user.
  3. if you are using the Mozilla Firefox browser as the default browser and you are not able to login into Simlink application then please check the Mozilla Firefox browser settings as below,
    a. Open settings of the browser.
    b. In General → Applications settings check navigraph-traffic-desktop content type action set as default as per the image.

    c. Retry login from Simlink application.

Please let us know, about the issue is fixed or not.


Ahir Vishal D.

Hi Vishal,

Yes the problem is solved and it is now working. Thanks for your time in sorting it out. It was clearly because I was not logged in to Sinlink, even though it was running on my PC and I thought I was logged in.

When I first loaded Navigraph and Simlink, the option to select the checkboxes didn’t really work and everytime I tried to log in to Simlink using the splash screen that came up on startup, it just tried to reinstall Navigraph. It must have been to do with my browser settings (Firefox) as you suggested and your solution to amend the Firefox settings has done the trick, It now starts up perfectly everytime I start my PC and the moving maps are working fine.
Great Job.
Thanks again.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.