Navigraph Simlink sign-in

Hi Ahir,

Neither of these fixes, or syncing the time worked. Any other ideas?

Thanks,

John

Hi aocbgoulart and John (Dirtbike),

Can you please advise if this issue is resolved.

Cheers
Ian

1 Like

Hi Ian,

The issue was resolved.

Thanks,

John

Nope, not working. Please wait for authentication…

hello, and tried to perform the troubleshooting as you describe it but the problem continues. still won’t log in

Nope, not working. Please wait for authentication…

I follow these steps,but I can’t sign-in

I have followed all recommendations for installing both Navigraph and SImLink and FMS Manager. I’m on XPlane 12 with latest versions of all apps. X1000 FPL does not recognize the presence of my flight plan link. Be advised that Windows solutions do NOT work. Thanks in advance, Anthony PS. I have SimBrief installed as well. In the meantime, Navigraph is doing a helluva good job at creating routes, and I’m learning how to program them manually, stupid YouTube videos as to how to do that, notwithstanding. :smiley: :smiley:

I’m getting a similar issue to this, but after three different browsers and resetting the configuration file, I still get an issue where I login and simlink instantly displays the “you have been signed out” message.

1 Like

Same for me, yesterday simlink was working fine but know I can’t sign in.

" [2023-07-31 09:53:23] [1.1.30.0607] [INFORMATION] Configuration (Charts) file or folder is missing. Recreated!
[2023-07-31 09:53:26] [1.1.30.0607] [INFORMATION] OIDC_refresh_tokens_CALL
[2023-07-31 09:53:26] [1.1.30.0607] [INFORMATION] OIDC_start_hybrid_flow_CALL
[2023-07-31 09:53:26] [1.1.30.0607] [INFORMATION] OIDC_open_browser_auth_CALL[https://identity.api.navigraph.com/connect/authorize?response_type=code+id_token&nonce=iBHWia6K4kq437ZM55K0rkkNbpokfsxi&state=XN4lFqg0lB0oHEUznxp3lYH1va7uBY1U&code_challenge=UhBnjMRB27ZF4242qctvajdFeYePXYGJkE5l0J8Wk04&code_challenge_method=S256&client_id=traffic-desktop&scope=openid+traffic+userinfo+offline_access+charts&redirect_uri=navigraph-traffic-desktop://oidc_sign_in_redirect&prompt=login]
[2023-07-31 09:53:46] [1.1.30.0607] [INFORMATION] OIDC_refresh_tokens_CALL
[2023-07-31 09:53:46] [1.1.30.0607] [INFORMATION] OIDC_start_hybrid_flow_CALL
[2023-07-31 09:53:46] [1.1.30.0607] [INFORMATION] OIDC_open_browser_auth_CALL[https://identity.api.navigraph.com/connect/authorize?response_type=code+id_token&nonce=Q0KH39yhcuN1JpuUOGOf0nKPwYQOq7QA&state=HCnoGFeghTk8L2PO9YwA7csFWxNpkgE1&code_challenge=CeuR9Jk9V4vEvFeQuIN_IgJdVuNf_Dde3fPyW-rGjA8&code_challenge_method=S256&client_id=traffic-desktop&scope=openid+traffic+userinfo+offline_access+charts&redirect_uri=navigraph-traffic-desktop://oidc_sign_in_redirect&prompt=login]
[2023-07-31 09:53:56] [1.1.30.0607] [INFORMATION] OIDC_refresh_tokens_CALL
[2023-07-31 09:53:56] [1.1.30.0607] [INFORMATION] OIDC_start_hybrid_flow_CALL
[2023-07-31 09:53:56] [1.1.30.0607] [INFORMATION] OIDC_open_browser_auth_CALL[https://identity.api.navigraph.com/connect/authorize?response_type=code+id_token&nonce=VSqY3NlQgk2DM0csyUuCakDfujCA7zAT&state=l1x4JEbqQZwfg1UY5MIhFvwMs9SIFxDn&code_challenge=h9Di3j9FcX3p4doAr8-IKNGPLVxc2NjP9nFmzfoHMoU&code_challenge_method=S256&client_id=traffic-desktop&scope=openid+traffic+userinfo+offline_access+charts&redirect_uri=navigraph-traffic-desktop://oidc_sign_in_redirect&prompt=login]
[2023-07-31 09:54:04] [1.1.30.0607] [INFORMATION] OIDC_authorization_code_flow[navigraph-traffic-desktop://oidc_sign_in_redirect/#code=cf0ec42ecc9a4d73e324cc1aa85f7973&id_token=eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiIsIng1dCI6IjA0X3JsNjNvV2ZBSVc3WEd4UWUzQzVEY3dkTSIsImtpZCI6IjA0X3JsNjNvV2ZBSVc3WEd4UWUzQzVEY3dkTSJ9.eyJpc3MiOiJodHRwczovL2lkZW50aXR5LmFwaS5uYXZpZ3JhcGguY29tIiwiYXVkIjoidHJhZmZpYy1kZXNrdG9wIiwiZXhwIjoxNjkwNzk4NDQ1LCJuYmYiOjE2OTA3OTcyNDUsIm5vbmNlIjoiVlNxWTNObFFnazJETTBjc3lVdUNha0RmdWpDQTd6QVQiLCJpYXQiOjE2OTA3OTcyNDUsImNfaGFzaCI6IjNqNi1XSURpSjdaeU1vcklsel90OXciLCJzaWQiOiI5ZGIxZmQzYzMzM2E5ZTkzNmI0NjRlZWI4NWMxNDBhNCIsInN1YiI6ImE2MWFjZmI5LTk5YTUtNGY5NS1iYjFlLWJlOTRhYmQwMzlkYiIsImF1dGhfdGltZSI6MTY5MDc5NzI0NCwiaWRwIjoibmF2aWdyYXBoIiwidXBkYXRlZF9hdCI6MTY5MDc5NjE4NiwicHJlZmVycmVkX3VzZXJuYW1lIjoiTGVvbGlvbklJSSIsInRvcyI6IjAiLCJhbXIiOlsicGFzc3dvcmQiXSwic3Vic2NyaXB0aW9ucyI6WyJmbXNkYXRhIiwiY2hhcnRzIl19.cRBnojc-xD__D6v_JRKge2uVUhgA2lAxlt1-2zqbSaRuZT1vEqUTjrMjFeGsS4LWbBymrQiobyTpFkBlOnPkjIppesJG-P_Y3sNG4Vg34TYZ3PKyek7cFJ6mq_VZBiQNB49NDgeSdq2PgQn5KI1eSeuPJvlrvBBPLy4r7i2XnDq_SKNFXV8o6VNVsY3bPUUCKO8_7otx_JoJFOh84L-LVg3Tt8KoGcBmc9cIWW9uLUCOtVohFS_7GjMLjaWCWqmGkdAnLVyCfIvf_r2bHaP-M6Z5D0jvdd7IkbvKQqV9_BA4vOb0MAzhnhwscohLYFMFv87MEOLceJi4-eBiSWr8Hg&scope=openid%20traffic%20userinfo%20offline_access%20charts&state=l1x4JEbqQZwfg1UY5MIhFvwMs9SIFxDn&session_state=uLukhJjouK8nbSS1VrnMHn45aAVDkM9mmKugJyKirNI.7f0f6a642cb3e4b50fd75ecff3635623]
[2023-07-31 09:54:05] [1.1.30.0607] [INFORMATION] OIDC_refresh_tokens_CALL[076cb6f78b58f5c981f2a27b3477f8c8]
[2023-07-31 09:54:09] [1.1.30.0607] [INFORMATION] OIDC_run_LastTokenGenrationTime_check[1690797249][1690797244][5][2]
[2023-07-31 09:54:09] [1.1.30.0607] [INFORMATION] OIDC_refresh_tokens_CALL[076cb6f78b58f5c981f2a27b3477f8c8]
[2023-07-31 09:54:09] [1.1.30.0607] [ERROR] OIDC_refresh_tokens ERROR:response json contains no ‘access_token’: {“error”:“invalid_grant”}
[2023-07-31 09:54:09] [1.1.30.0607] [ERROR] LoginController::login_oidcError[6][Your session has expired. Please sign in again.] "

Same Problem for me since 2 days. “You have been signed out”.
I have try all the above stuff, verified the Appdata propertues, tried to uninstalled completely Navigraph Charts, Simlink ans Navigraph HUB. I have also checked that the program is accepted in the firewall.
All reinstalled. After launching Charts, and the sim, it has worked for 20seconds before “You ve been signed out”. It has worked for 5 years, ans brutally stopped working !!!
You have changed the directories in which you installed it before. It was in Program Files, now it’s in Appdata/Roaming.
There is Navigraph stuff everywhere in my disk just like a pollution …
What did you changed recently ?

Hi,

Please check this.

After cleanup please reinstall the Simlink Plugins.

TR,

Vishal Ahir
Navigraph

Hi Vishal,

Thank you for helping.

I tried that yesterday without any success, even after a restart.

And today, everything works again without any other thing. I DO NOT UNDERSTAND ….

Best Regards,

Philippe

~WRD0000.jpg

I tried all the possibles solutions but Simlink NOT works.
Login, Logout, Loging, Logout …

What can I do now?

Im also having the same issue, simlink wont sign in

Hi Team,

Lets start with:

Using image, please upload latest
c:\Users\username\AppData\Roaming\Navigraph\Simlink\logs\simlink_xxxx.dlog.

Cheers
Ian

simlink_2023-08-31.dlog (40.3 KB)
simlink_2023-09-01.dlog (1.4 MB)
simlink_2023-09-02.dlog (40.6 KB)

I’ve tried uninstalling all the navigraph programs and reinstalling, I’ve tried uninstalling them and deleting every navigraph folder I can find and reinstalling, I’ve tried running simlink in admin mode, I can usually get it to work eventually but it always signs me back out before I can finish a flight, and never wants to sign back in again, I hit sign in, it brings up the browser where I sign in with my email and password and the sign in will flash up try again and am back to the sign in option again

Was this ever resolved as it appears that Navigraph support just left you hanging

I have the same problem and no solution