Cannot sign in to simlink

H, everybody, I can not log in anymore to simlink. It says in the log in window : “Please wait for user authentification.” But nothing happens. Logging in to the navigraph program is no problem. But only simlink does not work. Thank you very much for your help



I suggest you reinstall Simlink exactly as under:

Please disable any Antivirus and Firewall.

Click on Simlink icon in Windows Systray:


In Simlink Plugin Settings uninstall Simlink plugin from your FS, then completely uninstall Simlink using Windows Programs and Features exactly as under .

If they exist delete directories
c:\Users\username\AppData\Roaming\Navigraph\Simlink and c:\Program Files\Navigraph\Simlink

Then download and install latest Simlink for Windows

In Simlink Plugin Settings, check you have correct X-Plane path. If unclear, please post screenshots using Guide to posting Screenshots

Please let us know how you get on.


Hi Ian, thank you very much for your kind help. I have a mac computer. I deinstalled Simlink and navigraph charts and reinstalled both programms. But I still can not log in anymore in simlink.

Hi Ian, yesterday I tried to enter my username and password through Google chrome. That worked! Safari was the problem for whatever reason. Kind regards, Jan

Hi Jan,

Thank you for the update. I am glad it is resolved.

Happy flying.


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.