Simlink unable to connect

Hi guys , it’s been one month now and my simlink is still not working anymore. Everytime I click on simlink, it opens this white navigraph to sign in and it’s unable to do anything but "wait for user authentication. Now as you can see in the pics, there is this navigraph charts 7.1.27 which canoot be installed (it s grey). Dunno if it has to do with my issue. The charts are working fine but not the moving part . Thank you



You likely have Charts 8 but to be sure, please Download and install.

Current version is

For SImlink, please confirm your computer’s time is correctly set.

See also Navigraph Simlink sign-in - #10 by vishalahir


I had navigraph simlink since the beginning and everything was working fine with the moving map function.

So I have the last Charts *8 which can be opened in my PC without any problem with the correct credentials., same computer than before, new installation XP12 in a SSD 1To. I have deleted simlink and re installed from a last version. In my hidden icons, simlink is giving me access to 1/ signin, 2/ program settings and 3/ exit. Program settings is confirming that navigraph simling is installed in the correct XP12 drive and when I want to signin, the navigraph simlink appears waiting for an endless user authentication. I dunno what to do

jus to add that in the same navigraph simlink window try to open , I have this message “you have been signed out” which disappears . If you click on it before it disappears , you have a new msg “Authorization failed for traffic desktop”

Simlink unable to connect SOLVED

Switching from Chrome to Edge browser has fixed the problem , as the author of the post
Simlink “Unable to Reach Navigraph Server did!!!

My issue is that I can’t see charts on the EFB of MSFS 2020 for the PMDG B737-800. When I log into Navigraph from a browser, it recognizes me immediately, but when I start Simlink, it thinks I am someone else (FixedHelicopter578 or something likie that), which is not me. I can’t figure out how to get rid of that, which then causes Simlink to tell me I don’t have permission to see charts, etc.
Reinstalling simlink did no good. I don’t know what to do…


To use the Moving Map feature, please ensure that you are logged in with your Navigraph user into the Simlink application.

To sign out from the Simlink application, you can use any of the methods shown below:



Once you have signed out, please log in with your Navigraph user into the Simlink application.

If you face any issues with Navigraph Products, please feel free to contact us.

Best Regards,

Vishal Ahir

Thanks for responding.

I can easily log into Navigraph on the Windows computer I run MSFS on… in fact,

when I open, it shows me as already logged in.

But here’s the problem:

When I open the Navigraph-Simlink application, it shows the person logged in to

be “FixedHelicopter578.” So I tell Simlink to log out. That works fine. Then, I bring

up Simlink to log in, and it gives me the login screen. I enter my email and password,

just as I did above in Navigraph, BUT THERE IS A PROBLEM:

Two popups come up:

  1. the first says “Open Navigraph Charts” and gives an option to always open these types

of links in the associated app, and then a button labeled “Open Navigraph Charts.” That

button is NOT clickable. But there is another pop-up below:

  1. “Launch Application”. This link needs to be opened with an application. Send to:

(Then gives choice of Navigraph Charts or other, but neither is clickable, and on the

bottom, the button to “open link” is in some sort of “teach” mode… that is, there is an

animated arrow running back and forth between “Remember my choice” and the "Open

Link" button, and there seems to be no way for me to escape this and actually open the

link to let me log in.

Can you help me resolve this dilemma?


Erik Goodman