MSFS 2020 "... cannot detect a flight in your simulator"

Hi There,

I’ve tried and followed all guidance (including uninstall/delete; checking environment variables; etc.) and I still get this message.

The General tab also displays: “Not broadcasting flight data to server”.

Can you help me, please?

1 Like

I’m on the same boat, for some odd reason after SU6 I’m not able to get simlink to work (Web base navigraph to show aircraft live location)

1 Like

Same here. All latest and all fixes tried. No simulator detected for moving maps.

Hi Team,



There is nothing in SU6 that should affect Simlink. It works fine on my machine.

Please post screen shot of Simlink Status:

  • See FAQ - Simlink Install and Systray

  • In Navigraph Simlink Plugin Settings, for your FS entry press Uninstall Simlink.

  • Please use specifically Windows Programs and Features to uninstall Simlink:

  • If they exist delete directories
    c:\Users\username\AppData\Roaming\Navigraph\Simlink and
    c:\Program Files\Navigraph\Simlink.

  • Then download and install latest Simlink .

Also please post latest dlog from c:\Users\username\AppData\Roaming\Navigraph\Simlink\logs.

Please post a screenshot of Simlink Status:

Please let us know how you get on.


I’ve tried the uninstall and folder delete and reinstall without success, however I was on a long haul flight :airplane:. Must I exit the sim and restart the sim to verify? Thanks for your quick reply.

1 Like

You need to exit the sim to uninstall/delete/install.

You can post screenshot of Status using Guide to posting Screenshots and dlog whilst flying.


Hi Ian

Thanks for reaching out.

I’ve diligently followed the guidance, including uninstall all Navigraph applications, deleting in Roaming, checking environments variables, restart, reinstall with latest, etc. I went through this twice. Still getting “cannot detect a flight in your simulator”.

Obviously there was no “uninstall” in the Simlink Plugin because it’s MSFS 2020.

While there are no files listed in the Plugin logs window, there are a couple of log files in the folder.

I have a flight running on H145 LFML-KSEA (just for test purposes), airborne, here is the status/general:

When I press “retrieve flight data”…

Attached the logs, not sure if up to date…simlink_2021-10-21.dlog (73.7 KB)

simlink_2021-10-22.dlog (48.8 KB)

What additional info can I get you to help?

I’m sure that this is not necessarily relevant, but Navigraph charts in GTN750 works fine.

I also get this from the server occasionally “Server returned HTTP status 401”.


1 Like

Then I get this again…


1 Like

I know I got a Windows 11 update recently, could it be that?

Windows 11 Insider preview 22483? I’m on that and have no SimLink moving maps.

1 Like

Yeah me too, so could be that.

Edition Windows 11 Home Insider Preview
Version Dev
Installed on ‎10/‎21/‎2021
OS build 22483.1011
Experience Windows Feature Experience Pack 1000.22483.1011.0

Also, are we all flying the Flybywire A320nx? Experimental version here. Looking for commonalities. Simlink just not working!!


Same problem, all aircraft, not just FBW 320

Edition Windows 11 Pro
Version 21H2
Installed on ‎20 ‎Aug ‎2021
OS build 22000.282
Experience Windows Feature Experience Pack 1000.22000.282.0

Hi Lane,

Do you per chance have Windows 11 ?


Simlink per se has nothing todo with any aircraft/aircraft addon. It’s a tool for the sim and communicate with the sim and not with the aircraft what you have loaded.

When you don’t use the FBW A320, Simlink is working?


PS: by the way, I also use Win11 but the released version (x64 Professional)

I am here to report Navigraph inside MSFS not connecting (so it can’t show the location on the map).
I followed instructions here: Navigraph fails to connect to FS2020 to try and resolve, but with no luck.

FWIW, I am on Win 11.


have you only the MSFS on your computer or any other sim too, like P3D, FSX or XPlane?

When you have one installed, does Simlink work there?


PS: please can all check there clocks in windows, it should by in sync with the clock in Simlink and of course in sync with the real time :wink:


Only MSFS installed. Clock is good except for the obvious Z/Local time difference.