Navigraph fails to connect to FS2020

I have recently encountered an issue with Navigraph when I attempt to connect to FS2020 to show my plane on the navigraph map. Getting error box that say cannot connect to the simulator. I’ve tried starting NG before and after the sim but no luck. Recently installed Alpha Yoke and Logitech Radio Panel and driver plus updated to the latest database download from NG. Any ideas on what could be wrong?



  1. Use Windows to uninstall Simlink.
  2. If they exist delete folders c:\Users\username\AppData\Roaming\Navigraph\Simlink and c:\Program Files\Navigraph\Simlink
  3. Download and install latest Simlink .
  4. If still no moving map, please post screenshot of Simlink Status and Plugin Settings as per FAQ - Simlink Install and Systray
  5. Please let us know how you get on.


Thanks Ian! Worked like a charm. Have a great holiday.


Hi Blake,

You are welcome.

Compliments of the Season.


This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.