"Could not connect to simulator!" on msfs2020

Hi,

I seem to be unable to see the moving map on MSFS2020, while it works perfectly fine with x-plane 11.

I’ve tried to uninstall, using previously provided instructions (to someone else who had the same issue), but it did not help.

I get the following in the log, if it helps:
[2021-05-05 16:11:46] [1.1.21.0329] [DEBUG] Function_Recived:RESTUtilities::_get[]
[2021-05-05 16:11:46] [1.1.21.0329] [ERROR] SimConnectStatusView::SetStatus:1

Adding screenshots requested in previous posts describing similar symptoms.

image

Is there anything additional I can provide or try, to solve this issue?

Thanks
Gal

Hi Gal,

Can you please check is there any security software is blocking to Simlink or MSFS 2020?

And for some test can you please follow below steps,

  1. Close Simlink and MSFS
  2. Start MSFS
  3. Start Flight in MSFS
  4. Run Simlink
  5. Check Simlink is connected or not.

Please let us know what is result for above check.

TR,

Ahir Vishal D.
Navigraph

Hi Ahir, and thank you for the quick response.

The only security software in use is the Windows (10) security tools.

I get the same result if I start simlink after the sim.
With a log that looks something like the following (Reducted UUIDs and long strings in case they container security related information. But of course, I can send the full log).
reducted_simlink.log (1.5 KB)

Thanks!
Gal

1 Like