Simlink cannot detect FSX flight

I have read many posts about this or similar problems,
I have tried uninstall and deletion of leftover folders, then install of latest version.
Simlink is correctly installed as a plugin in the exe.dll file.
All programmes are running as administrator.
Signed in correctly.
Status shows “Navigraph Simlink cannot detect a flight in your simulator.
Not broadcasting flight data to server.”
NordVPN is not running.
Is it to do with folder permissions? I have tried to make sure that there are no access limitations on what i think are relevant folders.

Any further help appreciated.

Hi Me again with a further update to my problem.
On checking for logs generated by Simlink I found in Simlink Log folder (None shown in Simlink interface),
Reading both logs shows that Simlink is trying to connect with MSFS 2020. The folder path is clearly set for my FSX installation so why would it create logs for the correct times and dates I am trying to get Simlink to talk to FSX so that Map charts shows my FSX position?

I’ll try re-enforcing the path to see if that works.

Hi John,

Simlink cannot detect any FSX flight because FSX does not load the Simlink plugins while starting the FSX simulator. And this is because of the FSX plugin configuration file issue.

Please follow the below steps to fix the issue with FSX,

  1. Close running Simlink and FSX applications.
  2. Now open the FSX configuration folder,
    2.1 Press the Win + R key to open the Run window.
    2.2 Now type %appdata% and press enter, it will open the APPDATA folder.

    2.3 In the APPDATA folder you can find the FSX folder in <APPDATA>/Microsoft/FSX
  3. Take the backup of the FSX folder for recovery.
  4. Now reset the FSX configuration by deleting the FSX folder, Don’t worry FSX will recreate the folder with the default configuration.
  5. Start the FSX simulator, it will recreate the FSX folder and other configuration files.
  6. Stop the FSX application and reinstall the Simlink plugins by using the Simlink application.
  7. After installing Simlink plugins, please start the FSX and check whether Simlink detects flight.
  8. Done.

Please let me know if you fix or not the issue with the Simlink.


Vishal Ahir

Thanks Vishal,
I understand completely what you are saying but won’t that put my FSX back to a barebones state so to speak? Any tweaks to my FSX.cfg file, exe.xml and cameras etc?

Uploaded exe.xml file to show simlink addon.


Me again Vishal, just noticed in my tray icons, Navigraph FMS Data manager. On selecting open interface i get blocked warning. I’m sure I have set this to run as administrator already and made sure free access to folders, I
Screenshot 2023-03-07 211731
Don’t think this is related but none the less a pain. It worked a week or so ago. Screenshot attached.