Latest version of charts wont load on ipad

Hi all
Navigraph charts has updated on my ipad air (ios version 12.5.7) to latest version i presume: v8.31.0 from: v8.30.0 now charts wont load on this ipad, get a white screen for a few seconds then app just closes. also if i try to login though safari i just get a blue screen.
i have removed the charts app and reinstalled it , but get same outcome. also have cleard cache & history. any ideas please???

Hello! Welcome to the forum, thanks for reaching out.

That sounds curious, we have not changed anything in that area on our side. I have added some additional logging to your account - can you try to reproduce the issue and let me know? I’ll take a look and see if we can tell what’s going on!

Kind Regards,


If it helps with the investigation, exactly the same happens to me on my older iPad running ios version 12.5.7.

But on a newer iPad running 17.1.1 it works ok. Seems perhaps the update has made the app incompatible on older iOS versions.

1 Like

Thanks for the additional information!

I must admit that reading the initial post, I thought this was about getting a white screen when opening charts inside the application, not the entire application Navigraph Charts (with capitalized C) itself.
My understanding now is that the app crashes outright? Is that correct @Dickey ?

We have not intentionally dropped support for iOS 12 yet. But keeping support for these older versions of iOS is currently limiting us, and support will have to be officially dropped eventually.

We currently do not have old enough devices to test this on. Apple’s own developer tools do not allow us to test on such old versions, the oldest we get is iOS 13 :sweat_smile:

We’ll look into this briefly to see if there is anything we can do, but unfortunately I have a feeling that this is where we need to give up the support of iOS 12. Apologies for the major inconvenience that this may cause!

Kind Regards,

1 Like

So if the latest charts app may not support iOS 12 anymore, would it be possible to have an earlier version of charts that does support it.
I notice sometimes with other apps on this iPad it asks if you want to install an earlier version of the app that is compatible with your iOS version???
Yes Malte the app crashes straight away.


Hmm, that one is a bit tricky since again, we did not officially end iOS 12 support yet. According to all the Apple SDKs and tools used to build the app, iOS 12 should still work! In order for you to get the mentioned option to install an older version, we would have to explicitly drop iOS 12 support.

We will investigate this issue and discuss our options. I will let you know when I know more!

1 Like

I subscribed for a whole year and now charts does not work on my iPad. I’m on Xbox so I can’t use anything else for charts. Please come up with a solution fast.

I have excacly the same problem as @Dickey; the same iPad, ios version and Charts version. A white screen after opening the app, before it crashes. Funny is that I cannot see the app after downloading in my applist. Also it’s not possible to open the page. It gives a blue screen only.
(I didn’t read this topic before, so I just opened a new topic for this issue. Sorry for that)

Hello again!

We have built a version of the app using old (now unsupported) versions of Apple tools & SDKs and submitted it to Apple. Once they have finished their review, we will provide you with a link where you can join a testing group to find out if that helps you!

Please understand that if your device is not able to update past iOS 12, it is considered vintage by Apple themselves (Source). They do not actively support development for this iOS version.

Apologies for the inconvenience!

Kind Regards,

Just adding to join the conversation and follow. Same issue on my ipad after updating last night. It just immediately closes the app after trying to open. I have updated to the most recent ios software, uninstalled and reinstalled the app, and even reset the entire ipad as a last resort. Still the same issue. Hoping once the older version is released by apple it’ll work again. Thanks!


Hello again! Here is the link to join the testing group!


The link should give you all the necessary instructions to get going. Make sure to open it on the device that you would like to test this on!

Please let me know how it works out for you, either here or through the feedback feature of TestFlight.

Kind Regards,

1 Like

I’m getting the beta isn’t accepting any new testers right now. ?

Apologies for that, try again now!

Ok installing now :+1::+1:

Yes I’m in & will do a flight now , looks like it’s working again :+1::+1:

Thanks, I have accessed it ok and it appears to be working for me too.

For Testflight iOS 14 or higher is needed !

Hmm, no that does not appear to be the case. I can currently see that two separate devices, both iPad Air on iOS 12.5.7, have installed this version through TestFlight.

@Dickey Did you have any issues with TestFlight?

No issues with testflight version,full flight EHAM-EIDW worked like a charm…:slight_smile: ( yes ipad air 12.5.7)

Did you have TestFlight installed previously? Or did you download it now?