User WP - North Pole issue back again?

With the latest Cycle data (and maybe one before), I am getting User WPs at the North Pole again.

Here is the offending .pln file, as generated wit latest LNM & exported as a MSFS2020 .pln file

fpl.pln (5.5 KB)

Test Conditions:
PC with latest MSFS2020 Beta (as of 5/28/2022)
Only the navigraph apps in Community

Additional Information: If the pms50 GTN750 is added to Comminity, issue still exists in World Map.

But of the above User WP pln is loaded into the pms50 GTN750 (Pull down menu mode), it is read correctly and the user waypoints are correctly displayed, and then correct FP is displayed in the plane’s GNS530

BUT - with navigarph nav data "installed:

before even leaving the World Map, the North Pole issue is there

If the Navigraph addons are removed (uninstalled correctly from MSFS), then the World Map loads the example .pln correctly.

Thank you, we will check it and of course we will fix it when the new AAU2 is out … in most cases the reason are wrong/updated/removed airport icao codes in the sim- and/or world-updates.


1 Like

Thanks Richard,

If you are able to confirm or deny being able to reproduce it, that info would be greatly appreciated .

This is what the World Map should look like when the .pln loads correctly

Will do of course, but currently I´m not in the office to test this - I´m back at wednesday afternoon, so please be patience. On the other hand, I trust you and such reports because we have identified the issue in the last two world-updates - it was every time the same. No idea what that have todo with a loaded flightplan but we know how we can solve it …

Anyway, are you able to upload the pln-file that I can test it when I´m back?

Thank you,

Sounds good , No rush – you have the report – that’s what matters to me.

Another strange thing. (without navigraph)

In the Wold Map, the User waypoints do not show up as identified or named points.

But if you then EDIT the world map loaded plan, and add user waypoint s in teh world map, they do get their points identified.

Then save that world map as a .pln and Compare the two files. !!

A number of interesting differences.

  • The saved on has added tags

  • Even more strange, Dept & Arrival ATCWayPoint ids are changed, along with their lat & Lng

  • Alt are Leg WP altitudes are rounded to nearest 500 feet

  • Saved ,pln user waypoints are names Custom

have fun on Wednesday and beyond with what Asobo seems to have changed in the later updates !!

Hi again,
it seems you don´t have all WU updates installed … I have tested your example flightplan with both sim versions (official and beta) and the result is in both the same:

Here the loaded flightplan in the current sim version

… and here with the latest beta version

You see, exactly the same …

In nearly 99.9% its a missing WU, which is not installed (or not installed correctly). The reason why it´s so important to install all updates (incl. the World-Updates) is, that in these updates ASOBO/MS makes some changes on some airport ICAO codes (or they remove outdated airports) - the result is this north-pole issue. I can´t say why and what this has to do with a loaded flightplan but to install all WU correctly, the issue will be fixed automatically.

So, there is a unknown logic/connection between a flightplan which will be loaded with the WU. We have no possibility to look deeper what happened exactly (and why) that is only possible from ASOBO, sorry.

Again, to fix this - check, if you have all World-Updates installed. When not, that is the reason for the north-pole issue.

Hope that helps,

Thanks Richard, I will try install ALL world updates, and see if that fixes the issue.

Currently, since I typically only fly in the USA, I have not installed other country’s world update, (only the USA and Canada ones) so I do not have installed, any WU associaited with this particular FP.

I must say, the need to install ALL world updates, does not seem to make any sense to me, as a FP in an area without a WU works fine with non-user waypoints, and user waypoints just contain specific lat/lng values …
We will see…

Right, I´m with you here … I have also no idea what and why there is any “connection” but there is one, thats 100% clear and the “solution” is to install all WU. Not the best “solution” I know because as you wrote, sometimes it makes no sense to install a European WU, when you fly primarily in the US/CAN area.

My personal assumption is, but I can´t really verify it:
To install navdata updates, you must “clear” the default one - this will be done by a few XML-tags according the official schema in the SDK and I guess, there is somewhere a bug in the MSFS, a reference to the default airport schema, which possible will be “mixed”,“destroyed”, or whatever. I don´t know …

I will report this now to ASOBO/MS in the dev-forum, possible someone from ASOBO/MS can take a look on this. In the meanwhile, please install all WUs (sorry for that) and you will see it will be fixed …


Good luck in the SDK Forum. I have found them to be very responsive, if the item in question sparks their interest.

So what I am doing now is.

  1. Uninstall all WUs

  2. Re-boot

  3. Install ALL WUs (100+ GB)

  4. Re-boot (why not)

  5. Then see if the FP loads correctly

Note FP is in South America, and there is no South America update yet !

If it does, will try removing WUs, one at a time, to see if any particular one missing is the issue.

There might be an option to put the WUs into Addon Linker,and then be able to include or not include them selectively, without having to re-download each time.

Will keep you advised – I am now invested in finding an appropriate “FIX”

Tried all the above … No success…

Very strange.

Uninstalled the USA WUs I had installed, and the re-install ALL the available WUs.

Nothing in Community folder, except latest Install of navigraph (Removed & then re-installed)

Same issue with a FP (In Northern Hemisphere or Southern) with any USER WO, as set in World map, and then saved to PC (or cloud) and then Reloaded
Same North Pole issue

Note all airports, VORs NDBs, Fixes are OK, its just when there are User Defined WPs, all the User Defined ones end up at the North Pole

Since I now have ALL WU re-installed, I cannot believe this USER WP / North Pole issue is cause by the absence or presence of a particular WU

My gut theory is it is something in the way MSFS is reading FPs with USER waypoints in them

Will be interesting to see if ASOBO can fix the issue and if they tell anyone what was really causing it .

Remember, these saved User Waypoint FPs load 100% OK when the PMS GTN750 loads them … implying maybe its the World map’s issue in loading these flight plans


Hi Geoff,
first of all, thank you very!! much for your effort and your testing, including your feedback here. Much appreciated … After more than 20 years in this business, it’s still great to see so many folks here, like you, which try to help us to make our service, our products more and more better. Thanks for all what you’re doing … I know what that mean l, to install MSFS and to test it :woozy_face:

Very strange, because you’re the only one now where this doesn’t help … I have now checked nearly all reports here and in the official MSFS forum and in all cases, to install all WU’s fixed this issue.

But possible, I missunderstood you slightly, therefore as a conclusion to possible reproduce it:

  1. You create a flightplan in the WorldMap with custom waypoints
  2. You save this flightplan as PLN directly from MSFS (local PC or Clould)
  3. Cancel all, that you have no deps/arr airports and no flightplan is seen
  4. Load the created flightplan now again

→ result: north pole issue

Is this workflow correct?


Hi again,
I have now tried several different situations and I can´t reproduce it (PLN and FLT format). When I create a flightplan via the WorldMap (VFR direct GPS) and I add a few custom waypoints, the flightplan looks good after a re-load.

I havew tested the current MSFS version as well with (AAU2 beta) - same result, a planned and saved flight via the WorldMap with custom waypoints is loading correctly. Sorry, but I can´t really reproduce it.

Again, the very strange thing here is, that you are the only one (and really the only one, which we know) where this happen and where the solution to install all WUs doesn´t work. I assume any other issue here but we don´t have the same possibilities as ASOBO and therefore it´s nearly impossible for us, to look deeper into it.


HI Richard

Very strange, but maybe not so for MSFS,

I suspect its something to do with WT, and the way the world map now loads in a saved FP,

PMS50’s GTN750 can load the user waypoint FP correctly, and it is strange that ASOBO chose to limits the loading of a .pln to the world map, and not allow it once one had left the world map & were typically flying, but then did allow the loading of a flt MID flight… seems if anything, the wrong way around.

Maybe over the weekend, I’ll Image backup MSFS, and do a 100% re-install of the whole of MSFS – after quite a few “updates” its never 100% sure that something has not got corrupted.

Will keep you advised, and many thanks for checking this out at your end.


Yes… and the only items in the Community folder are your navigraph addons

All WU are installed

On MSFS Beta.… so getting all the latest Beta Update each time I start MSFS

Just finished a 100% re-installed of MSFS (registered in Beta).
Installed all WUs. Nothing else
Only the navigraph apps in Community.
Loading a user-wp FP, still give me WPs at North Pole

Maybe some others, reading this forum, could try out the following FlighPlan, with Navigraph intalled on their Sim, a d report back is they also get the User Waypoints at the North Pole. (or Not)

If you do, the more you can specify your system, the better

fpl.pln (5.5 KB)

@Casualclick … are you able to try the uploaded flightplan from Geoff on your system?

@N6722C Amando has exactly the same issue as you and after installing the latest WU, it was solved. Therefore the question to him directly …

I will test it also and will made a short video …


Hi again Geoff,
I have now tried again to reproduce the issue - I have now also deleted all from my community folder (what I haven´t done before). But also here, I can´t reproduce it - not with the current version nor the beta-version.

I have recorded a short video what I do - I have used your uploaded flightplan:


I have done two complete re-installs of MSFS (Premium deluxe), and still get the North Pole issue, even with all current WU, and latest Navigraph

Empty Community Folder, and no extra market place content installed

User WP FP loads fine without Navigaph installed. (with or without all the World Updates)

If it is working for you, would you be willing to try it without any World Updates, as it still seems odd that they should affect User waypoints,

Hi Geoff,

I will remove all WU´s and will try it again. I will start backwards, so starting with WU13, try, WU12, try, … my assumption is, it will not work after WU13 - but I´m curious now :wink:


… so only latest WU13 uninstalled, MSFS re-started and the “north-pole” issue is back, so reproduce able when at least WU13 is not installed:

… WU13 installed again:

Exactly the same requirements as before (empty community folder - only our data installed).
My assumption is still, that ASOBO updates the airports in every WU update (possible also AAU and SU, who knows) and therefore it looks, it´s enough when you install the latest one because than you have the latest airports and therefore it´s working …

Sorry, but I´m nearly 100% sure, that this issue comes from the MSFS updates - also when it looks strange and not logical, but it is reproduce able on my system here