World Update has reintroduced the North Pole issue

Yet again, following yesterday’s update, flight plans are shooting off to the North Pole. This is getting very tedious!

thanks for the info but without any details it is impossible to help you.

Here is a refernce link with a lot of information to this:


Corsica Task 3.pln (2.6 KB)
The attached .pln file, which has a departure and destination with 4 intervening waypoints, is a gliding task on the island of Corsica. With the current AIRAC active the waypoints are at the North Pole, with the AIRAC removed the plan is how it should be.
You’ve seen this problem before with previous World updates and fixed it with an AIRAC update.

Thanks, I will check it in the next couple of days. This update has also changed to generic airports and I’m pretty sure, that they have changed/removed some airport codes again.

I also see, that ASOBO has updates the navdata files also - same as in the past and it looks like this is also due to a bug in MSFS.

We update the AIRAC cycles in time as in real and therefore you see this bug only with our data.

Again, I will check the airports and the changes and will release a new revision.

Thank you

PS: I will keep you informed here, when its done

Here is something I found that might help narrow down cause, or maybe someone can explain why the ICAO Ident flag “fixes” North Pole issues.

I downloaded a .PLN from the MSFS Forum that a Community Manager posted for a fly-in event. He said he created it from the world map and saved it to a .PLN.

When I load that .PLN in the World Map, all “Custom” waypoints go to the north pole. If I open in Little Nav Map, they are fine, and if I export from Little Nav Map, it opens correctly in the World Map.

I compared the differences in one of the custom waypoint sections, and here are the differences. Deleting the SpeedMaxFP line from the “bad” .PLN has no effect. However, adding the ICAOIdent section fixes the North Pole issue.

I do not know what would happen with stock Nav data. I personally am on AIRAC 2308 with Navigraph data installed (of course :slight_smile: )

What’s special about the ICAOIdent item?



Thank you BigCow74 for your contribution.

I added the ICAOIdent items to the original .pln and it did indeed fix the problem.
What also fixed the problem was, as you have indicated, loading the flight plan into LittleNavMap and then simply exporting it as MSFS 2020 PLN.
(The original .pln was created in B21 Task Planner v3.28.)

I would also like to apologise to Richard. The tone of my original post was rude. You have delivered years of excellent service, and I ought to reflect that in my correspondence.

1 Like

I noticed this was marked as “Solved” but I’m not sure what exactly was solved? The issue is there, and I’m assuming the fix isn’t to manually go in and edit flight plans. Something is broken somewhere. Do we know what that is yet?

it serms that the missing “ICAOIdent” tag fix the issue. This is missing in the flightplan and ie. LNM add this to the flightplan but not the other planner which the OP had used.

The real root course is unknown because in an original flightplan from MSFS with using the stock navdata, this missing tag is also not included and it works.

As I have written before:
MSFS/Asobo changes,/removes airportidents now during every update. They also update their navdata files on the same time. So that’s their solution and you don’t see it because its during the update.

We must also create a new revision due this changes but in our case you must

  1. wait till we have released the new revision
  2. you must install it manually after every sim-update

… or:

  1. the flightplanner add this pseudo tag in his output

As I have written before, we will make a new revision if needed and if it fixes the issue.


Thanks for continuing to follow up on this issue :+1:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.