Unable to update cylcle 2209 with MSFS2020

Hello there,
I glistered for the yearly account, and today when I tried to update to the 2209 cycle I get error message

Now I checked that the 2 temp folder have the proper access here a snapshot

as well the community folder

Please advise what else I should check, and if I am doing anything wrong with the folder.
Your help would me much appreciated.
Thanks in advance

the error message said, you should check your Temp-Folder in the %localappdata% folder … so please copy&paste this into your file-explorer and check the permissions please


Thank you!


Hi Richard,
I don’t have a temp on this location because I moved the temp file to my E drive.

And I have given the proper auth for E drive for my temp Navigraph as you can see bellow.

So how can I update it then?
Thanks again

Hi Richard,
So restarted the PC, and tried to install and now it worked, can you please advise where is data installed, so I can go check that it is actually installed?

Ah cool thanks for your feedback.

Go in the MSFS in the PROFILE → CONTENT MANAGER and look for navigraph. Here you see if the package is installed correctly. You should see at least two entries, one base and one with the installed AIRAC cycle.

Like mine here:

So, you can check which package is installed and if the cycle is installed correctly.

Hope that helps

Perfect, thanks so much for getting back to me, much appreciated.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.