Software Update - Restart Now button not working (macOS) 2024-01-22

Its happening again, as described here:

Hello! Thanks for posting this.

This time, however, we cannot reproduce any issues on either Windows or macOS. What happens if you close the app, wait 30 seconds, and then open it again? It should update itself in the background.

We have tried to reproduce this issue on several computers (both Windows and macOS) to no avail. We see lots of users who have successfully updated the app too!

It seems that one other user has reported this issue though:

Could you upload your log file? Please follow these instructions:

  1. Press Win + R
  2. Type %appdata%/Navigraph Charts/logs and press enter
  3. In the Explorer window that opens, locate the main.log file
  4. Upload this file to your next post

Kind Regards,

I’m using mac. Its still having the same problem.

Reinstalling the app will fix the issue. But before you do that, please follow these steps so we can attempt to see what the issues could be:

  1. Open Finder
  2. Press ⌘ Cmd + Shift + G
  3. Type ~/Library/Logs/Navigraph Charts/main.log and press enter
  4. In the Finder window that opens, locate the highlighted main.log file
  5. Upload this file to your next post

Kind Regards,

The problem was that, as a result of a bug in a previous version, I had renamed the application to “Navigraph Charts 8.32” so I could run both and compare.

Just to confirm, do you mean that you changed the name back and now it works?