Software Update - Restart Now button not working (macOS)

There is a software update that came out within the past couple of hours. I tried to press Restart Now but there is no CPU or disk activity and the app stays unupdated.


Please close the app and start it manually from the Windows start button.

If you still are unable to get the app running, then download and install it manually from Navigraph

Sorry for the inconvenience.



Its the Mac version 8.30.0 according to Get Info. I tried quitting and restarting with no change. Button doesn’t do anything. I can press Later and use the current version as a workaround. When I tried to manually install 8.31.0 it says “Navigraph cannot be opened because it is from an unidentified developer.”

I’m getting the same issue on my Mac Studio desktop. OS 14.2 Sonoma. I get the update notice and click it but nothing happens. I restarted the app but get the same result. I’ll try downloading it from the link you provided.

Steve Haines

Hi Stephen, The download worked. All set. Thanks.



We’re investigating why the auto-update is not working as expected on Mac. Please standby.



Hi, I have Charts 8.3.0 Build 6336412403 on MacOS 13.6.1.

There is a software update prompt, but clicking Restart Now does nothing.

If I click “Later”, then go in to Settings > Check for Update, it’s the same result. Have tried rebooting, etc, etc.

Screenshot 2023-11-28 at 11.42.05 AM

Me too running macOS Sonoma 14.1.1.

Hello everyone!

We have identified the issue and are working on a fix. It will be available within the hour if all goes to plan!

Kind Regards,

And hello again! We have now made some changes on our servers, and the update should now be more smooth. If you are still having issues, please download the latest version and install it!

Download Here

Apologies for the inconvenience! It seems that our signing certificate expired without us realizing it.

Kind Regards,

Update works now. Thank you.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.