Simlink XPlane 11 stutters

Hi There,

I now this has been an issue before but I cannot find a solution.
XPlane 11 latest version 11.53r3 i think and latest simlink
When connected to XPlane 11 I still get that annoying FPS stutter and FPS drops. When this happens I disable moving maps and reconnect for it only to happen again a while later. It just spoils the flight so I end up disabling.
Is there a solution to this?


Hi Steve,

There must be Simlink Plugin was not updated with X-Plane.
Please follow the below steps,

  1. Close X-Plane and Simlink
  2. Run Simlink and open Simlink Plugin Setting window
  3. Now uninstall Simlink Plugin from X-Plane.
  4. After uninstalling SImlink Plugin, please install it again.
  5. Now Start X-Plane and check if the issue is fixed or not.

Please let us know the result.


Ahir Vishal D.

Hi there,

Sorry for long delay in getting back to you.
Did this a few times and still get the huge frame drops. Be happily at 40-50 then drop to 20, 15, 20 then back to 40-50.