Navigraph disconnects from Xplane causing severe stuttering

Flying Xplane with no issues initially. After a while Navigraph loses connection to xplane with a message that it couldn’t find simulator. At this point xplane starts to stutter really badly. Approx every second the FPS drops from 40 (I have it restricted) to 10 then back to 40 repeatedly. The sim then becomes a series of static images making flying impossible. I have had this happen twice now with different planes and different scenery.

Hi Graham,

Welcome.

Yes we are aware a few users have stutters with simlink. We are working on a new Simlink version.

In the meantime, please:

  1. See FAQ - Simlink Install and Systray
  2. In Navigraph Simlink Plugin Settings, for your FS entry press Uninstall Simlink.
  3. Use Windows to uninstall Simlink.
  4. If they exist delete folders c:\Users\username\AppData\Roaming\Navigraph\Simlink and c:\Program Files\Navigraph\Simlink
  5. Download and install latest Simlink .

Please let us know how you get on.

Cheers
Ian

I have just started to experience the same issue, after hundreds of hours with no such issue with Simlink.

Since the issue started (around 10 days ago) I have noticed no difference between online or offline flights (I always assume these things are caused by the VATSIM or IVAO clients!).

I have also noticed that the issue seems to get progressively worse. For example, I flew LIRP-EHAM yesterday and I noticed a tiny stutter every 1s while taxiing at Pisa, with no noticeable change in X-Plane’s CPU or GPU timing data. But by Brussels I was getting a pause every 1s, with my CPU times spiking each second to around 3x their natural size.

It was only then that I noticed that Simlink was disconnected again, and for the first time I wondered whether this was a Simlink issue. I closed/exit Simlink from the systray but that had no effect. Only when I disabled the Simlink plugin in X-Plane’s plugin admin did the issue resolve itself.

I hope this description helps de-bug the issue. Thanks for looking into it.

Meanwhile I’ll re-install as suggested above