Simlink.exe wont start

I can’t get [simlink.exe] to start. No icon is visible in the lower right of windows. I’ve tried reinstalling Simlink completely but it doesn’t help. The program that installs the plugin is working properly. Windows 10 and Perepar3d v5.0

Hi…,

Welcome.

  • See FAQ - Simlink Install and Systray

  • In Navigraph Simlink Plugin Settings, for your FS entry press Uninstall Simlink.

  • Please use specifically Windows Programs and Features to uninstall Simlink:

  • If they exist delete directories
    c:\Users\username\AppData\Roaming\Navigraph\Simlink and
    c:\Program Files\Navigraph\Simlink.

  • Then download and install latest Simlink .

Please let us know how you get on.

Cheers
Ian

Hi,

I read through the posts on the forum yesterday and have already tried to install on Simlink according to your description. Several times too.
When I try to start Simlink by clicking on simlink.exe, nothing happens. I get no error message and simlink does not appear in system tray. It also does not appear as a running process in Windows. I have also tried to delivate windows defender but nothing helps.
Also testing running simlink as an administrator.

Hi…,

Has Simlink ever worked for you?

Can you see it running in Task Manager?

Please check you are installing the latest from Simlink for Windows

Try disabling Antivirus when running Simlink

Please upload latest simlink_xxxx.dlog and P3D v5_yyyy_log.txt from c:\Users\username\AppData\Roaming\Navigraph\Simlink\logs

Cheers
Ian

Hello,

Answer your questions:

  1. Yes it has worked before but it is quite a long time ago now.

  2. No it is not visible in the system tray

  3. I have downloaded and reinstalled according to instructions including deleting old folders.

  4. It does not help to turn off virus protection

  5. What is in the latest log file for P3D is " Navigraph Simlink Addos (v. 1.1.19.0104) for P3D (x64) has loaded”
    No log is created for Simlink at all. The program does not even seem to try to start.

I work with computers and programming in my regular work so I am familiar with how to do

Hi there,
I’ve got the exact same problem with 1.1.21.0329: already completely deinstalled and reinstalled, to no avail. Nothing appears in the systray, ever. No logs are created either.
This is a brand new computer, so I can’t say it has worked before. However, the symptoms are identical to OP’s.
Thanks for your help

Windows’ event log reports this:

Nom de l’application défaillante NavigraphSimlink.exe, version : 1.1.21.329, horodatage : 0x60623430
Nom du module défaillant : Qt5Widgets.dll, version : 5.12.3.0, horodatage : 0x5cac5778
Code d’exception : 0xc0000005
Décalage d’erreur : 0x0000000000100d5f
ID du processus défaillant : 0x324c
Heure de début de l’application défaillante : 0x01d7320e7d320dd4
Chemin d’accès de l’application défaillante : C:\Program Files\Navigraph\Simlink\NavigraphSimlink.exe
Chemin d’accès du module défaillant: C:\Program Files\Navigraph\Simlink\Qt5Widgets.dll
ID de rapport : 324ae097-899a-42fa-8796-3a4fdf4a8c53
Nom complet du package défaillant :
ID de l’application relative au package défaillant :

Regards
Romain

I’ve briefly opened the dump:

ExceptionAddress: 00007ff9312d0d5f (Qt5Widgets!QComboBox::setCurrentIndex+0x000000000000000f)
ExceptionCode: c0000005 (Access violation)
ExceptionFlags: 00000000
NumberParameters: 2
Parameter[0]: 0000000000000000
Parameter[1]: 0000000000000008
Attempt to read from address 0000000000000008

Now why would this fail in some cases and not in others, I don’t know yet.
This is on W10 with the latest updates (ie . 20H2 10.0.19041.1), nothing special about the setup. I’ve tried the usual steps (run as admin, disable A/V, even installed on a different disk) but nothing helped.

Cheers

Romain