Restore not working in FMS Data Manager

Tried to use the Restore function in the data manager, doesn’t seem to work. It sees I have previous cycles (2013-1 and 2012-1), I select restore. The current cycle heading (2014 rev 1) changes color from Green to Purple, but it doesn’t actually restore the older version.

Thx…Ian

Hello Ian! Welcome to the new forum.

How are you able to confirm that the restoration did not succeed? What simulator are you using?
Please advise as I’m not able to reproduce the issue.

Regards,
Malte

1 Like

Hi Malte,

I confirmed by loading Xplane 11.51 after doing the restore, it still showed 2014 loaded. As well, the FMS Data Manager, after closing and re-opening, showed 2014 was loaded.

I have since manually restored 2013 to Xplane from a backup I have, and both Xplane and the FMS Data Manager show that 2013 is correctly installed.

If I get a chance I will reload 2014 again, then try a restore to see if I can reproduce the problem, and will let you know.

Thx…Ian

Glad to hear that you found a solution yourself!

What you’re describing makes me believe that something went wrong when restoring the backup. When I try the exact same procedure on my system, the downgrade is retained even after a restart of the FMS Data Manager.

There is another way of confirming what AIRAC cycle is installed into X-Plane 11. If you open the “Custom Data” folder in X-Plane’s route directory, you’ll find a file called cycle_info.txt. By opening this file in a text editor of your choice, you can confirm exactly what cycle is installed by checking the first line.

Hope this helps!

Regards,
Malte

1 Like

Whoops, forgot to mention that I checked the cycle_info.txt file too!

When I had selected the 2013 AIRAC, then pressed Restore from the dropdown list of AIRACs on the right of the X-Plane add-on line, it was as if nothing happened, no indication that any task had been performed.

If I used the Restore button on the upper part of the Data Manager (after selecting X-Plane 11.50), I did see another icon appear below the Sort button and alongside the X-Plane 11.50 line, a split second it appeared, impossible to really know what its indication was for.

Anyhow, for now, I do have 2013 loaded, which gets me around the Zibo issue (I am running a very old Zibo 3.35.6 and he only fixed the latest version) so I still get to fly!

As an aside, I noticed while looking at the restore function that the Data Manager backup index seems to have my 2011 cycle header wrong, you can see via the picture I attached as well as these lines from the backup.index file. Never caused me any issues, just curious what may have caused this.

Great, then you did all the right things!

Something is clearly not working as intended then. The restore process triggers a loading indicator and the process definitively should not be over in a split second! This is how it should look:

image

Would you be able to provide the relevant logs from /Users/<user>/navigraph/fms-manager/logs? If so, please attach them to your next post and I’ll investigate!

Regards,
Malte

1 Like

Yup, that is the icon that flashes for a microsecond, I only see it when I use the Restore button up on the Navigraph logo area, never saw it when I selected Restore from the right of the add-on line.

Have attached the 3 logs from yesterday. I don’t have the exact time I attempted the restore, my guess is around 10:15-10:30 A.M local time, so the 102903 log might be applicable.

I have a flight in progress now, but if you need, I can always try to recreate later.

Thx…Ian

20210104-102621.log (19.3 KB) 20210104-102903.log (29.3 KB) 20210104-114620.log (10.7 KB)

Thank you for your cooperation!

Looking at the provided logs, we’re unable to find anything obvious.

If possible, please do try to recreate the issue, it would be much appreciated! If you are able to, please avoid installing/downloading any AIRAC to other addons in an effort to reduce the noise in the logs.

Again, thank you for your patience!

Cheers,
Malte

1 Like

Okay, ran a few tests, logs attached.

I am running MacOS 10.15.7 - the latest update from December
FMS Data Manger v 1.7.0.0717 for Mac

Test 1 - go from 2013 to 2012 via restore icon on XPlane 11.50 add-on line
This resulted in FMS Data Manager crashing, data stayed at 2013 - Apple log also attached

Test 2 - Tried same test as above, go from 2013 to 2012 via restore icon
FMS Data Manager crashed again - Apple log attached

Test 3 - Tried to go from 2013 to 2014 via restore icon
No crash, but it didn’t restore, data stayed at 2013

Test 4 - I manually copied 2014 data to Custom Data folder, tried to go from 2014 to 2013
Nothing happened, data stayed at 2014

Let me know if you need anything else…ianQ

20210107-093522-crash 1.log (10.8 KB) 20210107-093756-crash 2.log (10.8 KB) 20210107-093937 2013-to-2014.log (11.0 KB) 20210107-094238 2014-to-2013.log (11.0 KB) FMS Data Manager crash 1.txt (69.0 KB) FMS Data Manager crash 2.txt (75.8 KB)

Hello Ian! Sorry for the late reply.

The logs look fine, there’s nothing there even hinting about a crash. However, there are indications of some downloads failing due to some unknown reason. What is your firewall and antivirus configuration like? And what version of macOS are you on?

Thanks again for your cooperation and patience!

Regards,
Malte

Malte,

I have firewall disabled, and no antivirus software configured.

I am rural, so at times my internet can be a bit slow, maybe drop for a microsecond every now and then.

I am on the latest version of Catalina, 10.15.7 with December’s supplemental installed.

Ian

Would you be able to try using a more reliable connection? Perhaps a 3G/4G mobile network?
We’d like to rule out the connection as a cause, if possible.

Regards,
Malte

It’s not that my internet isn’t reliable, it rarely has issues, but every now and then, maybe once a month or longer, there is a slowdown that lasts for a millisecond, and that can throw Navigraph off, causing it to lose connection with Xplane. Some of this you folk have addressed recently, Navigraph isn’t quite so sensitive any longer.

I could run off my cell phone for a test if you wish, should I be doing something else at the time, or just using Navigraph with Xplane?

Ian

Please do that, try to not do anything else at all while restoring!

Do you have any other machine to test on? I will bring this to the developers and try once again to reproduce it locally but so far I’m puzzled as to what is causing this issue.

Thank you for your patience!

Regards,
Malte

Malte,

Tried it using my phone as the network, and running from my other iMac.

First attempt to restore 2012 from 2013 resulted in FMS Data Manager crash, logs attached.

I then loaded 2014 into Xplane as FMS Data Manager only showed 2012 as a restore option for Xplane even though it offers many more for Little Navmap.

Second attempt to restore 2013 from 2014 was the same as my other machine, saw the restore icon for about a microsecond, no restore occurred, no error. The only noticeable change is the “Most Recent Version Installed” symbol changes color to purple, but still shows 2014 rev 1 as the version. Next time I bring up FMS Data Manager, the symbol is green again.

Ian

20210117-192440.log (10.8 KB) 20210117-192859.log (11.0 KB) FMS Data Manager crash log 20210117-192440.txt (71.9 KB)

Hi Ian,

Some lateral thinking - do you need old 2012 and 2013? Will you actually load these or are you being careful if you lose latest?

If the backup database is corrupt It might be expeditious to remove the backed up database and start afresh ?

Cheers
Ian

I have no need for any previous AIRACs via the FMS Data Manager, I have them backed up manually as well.

Ian