Randomly losing my Navigraph subscription login

I am constantly and randomly losing my Navigraph subscription login in the Fenix A320 EFB (same happens with the Simlink app). Tried searching for a solution (forum and internet) and found no working solution. I have also uninstalled and reinstalled all Navigraph software (Simlink, Charts, Navigraph Hub and Navigraph FMS Data Manager) with no results either.

It’s rather annoying the need to login 2 or 3 times during the flight (AFAIK, it should be a one time action). It’s particularly bad when it happens during heavy workload (e.g. on approach and landing) because all of your planning is lost.

Any help would be much appreciated.

7 days and 0 replies. Am I the only one suffering from this issue? :face_exhaling:

Hi! Sorry for the late response, your post slipped through unnoticed somehow!

Let’s begin with making a few things clear! You have posted in the Simlink/Moving map category, yet you mention the Fenix A320 EFB as well as all of our other software.

Are you having the same issue in all of these apps?

Kind Regards,

Thanks for reaching out!

It am also randomly losing my login with Simlink, Charts, Navigraph HUB, Navigraph FMS Data Manager along with Navigraph functionality using the Fenix A320 EFB. Basically all of the Navigraph related apps. I have cleared all the devices from my account, uninstalled and reinstalled all Navigraph software but it didn’t fix the issue.



I have added some additional logging on your account. Please report back again when you have been randomly logged out again in the apps.



Please also make absolutely sure that your computer clock is correctly synchronized. Just a few seconds is enough to throw you out of our apps due to our security standards.

Kind Regards,

Don’t know if @stephen did anything, but after his reply I have tried the simulator 2 days in a row without a single log off. I’m assuming the issue was fixed.

@skysail AFAIK I have not experienced/realized having problems with my PC clock.

Thank you very much for the support. Kind regards,

Don’t know if it’s related, but after the AIRAC update (of today) I started experiencing random log off’s again. Simlink once and 2 or 3 times on the Fenix A320 EFB. :woozy_face:


Hmmm, the extended logging does not apply to Simlink.

Could you open the “Logs” tab in Simlink and locate the one closest to when you had this issue? Alternatively, if you see the issue again - immediately send the latest log.

Sure do!

simlink_2023-11-03.dlog (23.8 KB)
simlink_2023-11-02.dlog (6.4 KB)


Thank you! Much appreciated!

Those logs seem to indicate that you have connection issues, your computer is not able to reach our servers (which are hosted by Amazon and are live and well).

There are heaps of messages related to connectivity issues, seemingly at random with around 4-20 minute intervals :thinking: If such a connection issue would occur when authenticating, you would likely be signed out of Simlink! This would make it look like you are signed out at random.

This could be a local issue with the router. It could be due to a bad DNS server. It could be a firewall. It could be the ISP. It could be almost anything, but unfortunately, there is little that we can do about it!

I will ask a colleague with better knowledge about Simlink specifically to see if there is anything that I have missed!

Thank you very much for the feedback! That is indeed odd… as I run FSLTL, REX Weather Force, Fenix A320, FS Realistic, FSHud, SPAD.neXt, FSiPanel or even the simulator itself (photogrammetry) and I haven’t experienced any connection issues so far.

Please let me know if you guys are able to dig it further…

Kind regards,

I don’t see a reason why any of the software that you mentioned would have issues with these kinds of connectivity issues, except maybe REX. These connection issues are short (seemingly a couple of seconds at most), and unless you are authenticating at that exact moment - there should not be an issue!

There are lots of logs where Simlink just fails to send your position to our servers, but you probably would not notice if just one update went missing!

Also note that the nature of this issue, being network related, means that it could only be affecting your access to some servers, not all. For example, we have had documented cases where AT&T in the US have had issue connecting not just to our servers but any AWS-hosted server. Firewalls or changed DNS servers could have the exact same effect - no problem with some servers and issues with others.

In this case, your computer fails to resolve our domains. That basically means that it knows the address to the servers location, but it does not know where that address is actually located (if that makes sense) and is therefore unable to connect. It is fully possible that you are able to reach our servers, but in these cases your computer is not able to determine where to connect to!

I am not doubting you explanation (I do get that some sort of network issues might be messing with Navigraph)… I thought FSLTL which is also an injector (live data) and the Fenix (side app) that requires connection to their server in order the have the airplane fully working would suffer from that… and also because I am not experiencing problems with loading photogrammetry (like many other simmers do).

Speed test taken a few minutes ago (and this is “rush hour” at my location):

I think we agree with each other!

Also, another thing that can affect this is if the network card is in “sleep mode” - such as immediately after waking up certain computers from sleep. Probably good to mention that as well!

Had several Fenix EFB log offs and at least one Simlink disconnect. Check out this log please. It shows a different error. Maybe it can provide more insight.


simlink_2023-11-04.dlog (10.6 KB)

Thanks for the additional log! I don’t immediately see any new errors in there, just the same network issues. It’s currently the weekend, but my colleague will get back to you as soon as possible for more help!

Hi @Caroto10 ,

Thank you for your log files and sorry for the late reply.

As per the log files, Simlink Is cannot connect with our navigraph server. This can be possible if Simlink is blocked by some security application or proxy or VPN setup on your network settings.

Please check the following troubleshooting points,

  1. Allow the Simlink application to access the network from the security or antivirus application.
  2. Make sure your system OS time is sync with the internet.
  3. Disable and proxy or VPN setting from the network and check it again with the Simlink application.
  4. If the issue is still there then please clean up the SImlink configuration by this. After cleanup please reinstall the Simlink Plugins to the Simulator.

Please feel free to inform us of any issues.

Kind Regards,

Vishal Ahir

Thank you, Sir! Will do.

I’m considering the possibility I could have something messed up with my OS install… but with thousands of hours and addons on the “MSFS realm of things” I am unwilling, to go that route (clean OS + MSFS Install). I will try to see if you solution helps.

BTW I have Kaspersky Internet Security and Nord VPN, but I always fly without them to save system resources. The only thing I would have running, security wise, is the Windows Firewall and Windows Defender. And Navigraph software is allowed under the Windows firewall rules.


Are you still having issues?

Kaspersky does not sound like something I’d like to have installed on my computer (see allegations here), but either way, there is a possibility that they installed a self-signed certificate or something of similar nature on your computer. That is quite common for these “internet security” apps, and it will inevitably cause problems.

If you are still having these issues, please try to uninstall Kaspersky and see if that makes any difference! Not sure that they will correctly clean up after themselves, but you have to trust them I guess.

Kind Regards,