No Simulators detected

I have MSFS 2020 installed on C drive moved long since to a faster SSD and was working flawlessly with NavData Center. The only recent change to my system has been an otherwise uneventful update to Win 22H2 64pro. Now, suddenly, NavData Center is unable to detect MSFS.
I have scoured the forum extensively and tried all the methods suggested, uninstall-reinstall, check security permissions and ensured that they are all as they should be giving full control access to the user named in the installation.
I’m running Navdata 1.0.12 which hitherto worked fine and have the latest update to MSFS which also works normally.
I have been able to manually update my PMDG Boeing aircraft but have no way that I can divine of updating the simulator itself (likewise for my Fenix A320).
The UserCfg.Opt file appears to be OK and its last line points to the C drive installation, viz.,: C:\Users\ronha\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\Packages"
The links from the C drive to the SSD are all functional, all vetted for security permissions etc.

I confess to being completely stumped by the mysterious failure to detect and hope that more experienced and savvy minds can help.

Ron H

Hi Ron,

I believe the last line in Usercfg.opt points to where you have installed MSFS. So for example, in mine it it says:

InstalledPackagesPath “F:\MSFS”

Compliments of the Season


Ron, additional to Ian´s answer … I assume, this path in the UserCfg.opt is wrong.

You wrote, that you have moved the MSFS to a faster SSD drive, that means this drive has an other drive-letter, possible also a other folder structure, right? Now, when you have this line in your UserCfg.opt file:

InstalledPatchesPath: C:\Users\ronha\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\Packages

then it means for me, this path is wrong and is linked to a wrong location …

So, follow these steps:

  1. close the sim first,
  2. open the UserCfg.opt file with notepad or any other text-editor
  3. go down to the last line with InstalledPackagesPath and correct the folder name (it must be the root-path, where the MSFS is installed)
  4. save and close the editor
  5. reboot your PC - IMPORTANT!!
  6. start the Navigraph Navdata Center and look, if all work as expected

Hope that helps,

Continuing the discussion from No Simulators detected:

Thank you both for your suggestions. Unfortunately the problem remains unresolved. The original location of MSFS is:

In this folder there are the following folders: AC, AppData, Local Cache, Local State, Roaming State, Settings, SystemAppData and TempState.
Each of these now “empty” folders has a link that connects them to their populated equivalents located on the “S” drive. The S drive has two folders:

  1. WindowsApps that is owned by Trusted Installer and I assume contains MSFS programme and executive file etc. Without taking ownership I have no current access to its internals.

  2. WpSystem A subfolder of WpSystem is AppData that itself contains: Local which in turn contains Packages that contains Microsoft.FlightSimulator_8wekyb3d8bbwe.

Microsoft.FlightSimulator_8wekyb3d8bbwe contains the linked populated folders: AC, AppData, Local Cache, Local State, Roaming State, Settings, SystemAppData and TempState.

I did edit the UserCfg.Opt file pointing it to S:\WindowsApps on the assumption, as mentioned above, that it contained MSFS installation, rebooted and retried Navigraph NavCenter with no success.

Since I suspect that the simulator writes UserCfg, I started it and was faced with an unexpected “update” of files pointing to Installed Packages Path S:\ WindowsApps. This I did not do and exited the simulator (which has been and is working normally).
I then renamed UserCfg to make it unusable and restarted MSFS. Sure enough, UserCfg was recreated with exactly the same last line as it originally had viz.,

InstalledPackagesPath C:\Users\ronha\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\Packages

So, I remain entirely flummoxed. I have no idea why what was a fully functional NavCenter now suddenly cannot see MSFS, not having changed anything, and I have no idea what governs where NavCenter looks for the root installation directory, why it should be different to that established by the Microsoft package or what to do next (sacrifice a mock chicken maybe?).


Just an addendum. In the Community folder there are two separate folders of interest that appear to me to be related to the preceding Airac cycle since they are dated 11/26/2022.

One is named navigraph-navdata-base. It contains folders and two files:

Weirdly, ContentInfo contains two folders:
Navigraph-navadata containing cycle.json and a jpeg thumbnail
Navigraph-navdata-base containing ContentHistory.json

Why there is this folder structure with its apparent duplication of folder name I’ve no clue.

The second folder of interest is named navigraph-navdata. It also contains folders and two files:

This Contentinfo folder contains folder Navigraph-navdata in which there is ContentHistory.json and the jpeg thumbnail as above.

The remaining folder Scenery, and the two files are identical to those above.

I realize this is a lot of information to process, for which I apologize. I’m not entirely sure of its relevance, save that it may show NavCenter was working. Do these folders make any sense and what would happen if they were removed? If I tried another uninstall of NavCenter without them would that replace them?


After what I can only describe as a frustrating adventure involving a complete uninstall and reinstall of MSFS, the scenery from OrbX, GSXPro, all PMDG Boeings, FSUIPC7 (and Uncle Tom Cobley and all), Navdata Center was the the only programme that did not seem to know where MSFS was (community and official folders now on SSD Drive: \MSFS, a convenient bonus from the adventure).

A random google brought me to Navigraph Forum and the old news about Fenix Sytems A320 creating a problem with an earlier version of Navdata Center. However, the thread seemed to indicate that this problem had been resolved.

Before the most recent Fenix update Navdata Center was updating Fenix along with all else. Perhaps it was this update that was the root cause.

Nonetheless, using an uninstaller, I did a complete uninstall of my Fenix, not holding out much hope (Oh me of little faith), clicked on Navdata Center and to my amazement and joy MSFS and its add-ons are all Airac cycle up to date. Good start to the new year.

The masochist on the shoulder opposite the rationalist says I should reinstall Fenix and see what happens. At least the fix will be straightforward if the problem is rekindled.

Happy New Year to All


Hi Ron,

If it is not broken, don’t fix it… :slight_smile:

Note in Navigraph Navdata Center, the Fenix shows in separate “Installed outside Simulator” section.

Happy New Year


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.