Nav Data Center

Nav Data Center not locating MSFS Sim, just reinstalled navdata



Please post screenshot of error message using Guide to posting Screenshots.

Also please advise path to your MSFS - is it standard?


HI Thanks for quick reply, after much fluffing around uninstalled etc. Finally got it going. Again thanks

Hi Paul,

You are welcome.

Happy flying.


Hi there!
I’m suffering the same problem. After have followed the procedure explained here (FAQ - Navigraph Navdata Center could not find/access simulator) nothing’s changed. Yhe nav data center still keeps me telling no simulator detected.
how can I solve
All the best!

1 Like

Hi Fede

Like I said , I uninstalled nav. data centre entirely and did a clean fresh install to the destination it wanted rather than move to where I wanted. Started it up and after an anxious moment when I thought it rejected that too, it came alive and was able to download update to MSFS`Nav Data Center, Can confirm Airac updated in PMDG
Sorry all I can offer, hope it helps

Hi Paul,
many thanks for your kind reply. I tried to uninstall and do a fresh clean, but nothing has changed. Maybe it depends on the destination? What’s your path? Many thanks!

I was having the same issue. Try the following…

  • Open task manager
  • Find Navigraph Simlink and press end task
  • Ensure you have completely uninstalled any versions of Navdata Centre
  • Re-install Navdata Centre to default location

It should now work!

It was simlink blocking it for some reason….

Sorry if this doesn’t help but thought it would be worth trying for you as it worked for me😊

“C:\Users\Paul\AppData\Local\Programs\Navigraph Navdata Center”

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.