No simulators detected by Navdata Center

Ok I’m having this same issue where I get the message stating “No simulator detected” when I start Nav Center and MSFS is not running what was the resolution for this ???

Please confirm you are running V 1.0.10 of Navigraph Navdata Center.


Where is your MSFS installed?

As a test, try restarting machine and disabling Antivirus and Firewall, and running Navigraph Navdata Center.


Same problem here after installing cycle 2209. Not sure where i can find the log file. Also turned off Antivirus, still same issue. Using latest version 1.0.10 and re-installed it too.

any idea, can we get some support, currently beta testing and need this solved!


Which beta do you mean? Our charts app? For that you don’t need the Navigraph Navdata Center.


Hi Richard, sure do not need right now, but want to ensure using the correct data set with MSFS!

Ah understood thanks, and you are using the current MSFS version 1.26.x right? I mean not the SU10 beta? Because the current version is not beta compatible …

Where ia your MSFS installed?


That is correct, not using SU10 beta.

installed as follows:


Program as per registry:
“Path”=“C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.26.5.0_x64__8wekyb3d8bbwe”

still no change, why can the path not be added manually, so app can find it?

That’s the question I asked myself already, too. But that’s the problem, just questions here and no answers. My solution for the moment is the fallback to X-Plane 11, FMS data manager is far better and works.

It is not easy to fall back to XP11, after using MSFS and getting spoiled with the scenery realism. Agree FMS data manager works much better and one can select the folder where it installs too.

Any idea Richard, on how to solve this?


still no resolve on this!

We are currently look, if we get more information from the system to get a better overview what happened.

An updated version of the Navigraph Navdata Center (v1 0.11) is ready and will be released as soon as the SIm Update 10 is out.

In normal case (nearly 99%) this is a permission issue on your system, that results in such messages because we try to look for community path from the MSFS folder (which you have posted). When the permisions in the MSFS folder are to low (ie. installed with an other user), the NNC can’t read this folder and returns exactl with this message.

Anyways, we will try to get any more information when such messages appears. A manual select of the path is more error prone - thats an experiance what we had made with the FMS Data Manager since the last 10 years. Also the MSFS path is everywhere equal.

We will come back, as we have an answer, in the best case, a solution for you.

Thank you very much for your patience

thank you for the update Richard, fyi tried to run and install it as administrator with same results. It was working without any problems since originally installed and only occurred recently. Looking forward to a fix.

Sorry Norbert, not a friendly answer. I have forgotten so say “hi” or at least “good morning” :slight_smile:

What you can try again is, to un-install the NNC. Reboot your PC. Delete and clean the complete NNC folder (if something is still there after the un-install process).

Try to re-install the NNC, important reboot the PC again and try it again, if the path is found now.

This works only when the permissions are correct and I trust you here when you wrote, that it was working before.

Also please be sure, that the sim or any process of the sim aren’t running (therefore the multiple reboots :slight_smile: )

Thanks & a nice day

Hi Richard,
did exactly as you described and rebooted twice, deleted NNC folder in between, re-authenticated and have the same result, “No simulators detected”.
Installed as per previous working version (only for me) and not as administrator. Any other idea I can try?

Hi again Norbert,
thanks for the feedback - we are currently looking into the internal log files to analyze your case. Sorry, we need additional time please … thank you!


Gentlemen (@nfinger ,@Yzerman19),
we have now activate a internal logging for your both user-accounts to look what happened behind the scene.

Please, when time do following:

  1. close the Navigraph Navdata Center completely (means also in the tray - not only with the X in the app)
  2. start the Navigraph Navdata Center

Alternative - reboot your PC and start the Navigraph Navdata Center

Please let me know, when you have done this … you can do this multiple times. Each session will be logged and we can look in a second step what happened … I´m still pretty sure that this is a permission issue somewhere but we hope we find it via our logs …

Thanks to you both for your patience and your cooperation

Hi Richard,
As suggested, I have completed the starting of NNC, closing it, opening it again a few times. Also run it as Administrator. Please let me know what you find and how to solve it. Thanks