No simulators detected by Navdata Center

Thanks Norbert, I see the log-session now …

Where do you have installed the Navigraph Navdata Center?
In C:\User\norbe\AppData\Local\Programs\Navigraph Navdata Center ??

Can you look, if you have this path and when yes, what is included in this path? Because the NNC try to load the app from there and this failed. The subscription check and the package loadings are ok so it looks not a virus or firewall issue … I´m still thinking it´s a permission issue

Thank you,

The NNC app is loading fine and the path for NNC is as per your post: C:\User\norbe\AppData\Local\Programs\Navigraph Navdata Center

Hi Richard,

I just want to throw my hat into the ring. I’m having the exact same issue. I get the same blue screen shown about with “No simulators detected” right after the “Sign In” screen flashes. I assume that it’s auto-sign in to my account.

Please add my account to the watch list and de-bug logging.

Rich Boll
Wichita , KS

Thanks a lot so far, I’m on a short trip this weekend and will go on on monday.

Hi Norbert,
thank you for the confirmation - I have one request:

  1. Please can you un-install the NNC
  2. Reboot the system
  3. Create a own folder on C, D, E … drive (where ever you want)
  4. Install the NNC into this folder please
  5. Reboot the system
  6. Try to start it …

Thank you,

No problem - we have activated the extended logging on your user, so whenever you find time - so let me only know it, when it´s done - according these instructions

Thanks and have a safe trip

Hi Richard,
followed your procedure to the letter and created a folder on E:\NNC - installed it there but unfortunately same result “No simulators detected”. Hope you can find the problem in the logs.

Hi again Norbert,
is it correct, that you start the NNC in Chrome? I have seen that you´re a beta user also and you start our chart-app with Firefox. Is there any reason for this?

Also, can you check the following registry key:
if the (Default) value is pointed to Google Chrome

When not, here is the registry-file for that - copy & paste it on your desktop and double click it - after the installation was successfully, reboot your PC and start the NNC.

StartMenuInternet.reg (232 Bytes)


PS: you can remove the test-installation and can install the NNC on your place what you prefer - thanks for that (please, don´t forget the reboot after the installation)

Hi Richard,
I use Firefox as default browser and also for Beta Navigraph Charts. I do not use Google Chrome as my default browser. Is that a problem as NNC is in its own folder and its own app? I do not wish to use Chrome as default browser, if possible?

No Nobert Firefox is good (I use it also and not Chrome) - the strange is this only, that in the log I see Firefox as platform for the charts and Chrome as platform when you use the NNC. Therefore the question …

However, can you install the registry-key … it´s not the for the default browser, so you will keep Firefox but this key is normally important for the NNC. Simple double click on it, when you have downloaded it on your desktop. After that report the system please.

Thank you,

Installed the registry key, uninstalled NNC, installed NNC, rebooted in between every time and problem persists. still “No simulators detected”.

Hi Richard, did this procedure a few times now.

After updating to SU 10 and NNC 1.0.12 still “No simulators detected.” in NNC. It’s quite annoying.

same here, issue remains with no resolve in sight.

Richard, Can we get a refund or manual data update for MSFS data import?


MSFS Fenix also need data manual update and aerosoft CRJ too.

Hi guys, sorry to hear you have problems. In order to find out the issue, I am preparing a special version of NNC for you that will provide more extensive logging for us. Will update you with an installer later during the day.

Kind regards,


thank you Markus and looking forward to it.


Did I miss the update? Still waiting on the special version from yesterday!

Last night I took my time in deinstalling the whole sim incl. 3rd party stuff and deleting manually all files and folders that remained after this procedure. After that I installed everything from scratch. A lot of work, but in the end now everything is working fine for me again. I hope I’ll never read this message again.

Thanks for the update @Yzerman19 … As I wrote, in nearly 100% such cases, it´s a permission issue - specially, if the UserCfg-File can be read by the Navigraph Navdata Center or not. Because this file contains the package-path and is necessary to update the data.

But we get to less logging information out from the NNC and therefore we are working on the implementation of a special update version with more logging information, which we will offer user with such issues.

Thanks again for the update, great when it´s solved now …
Have a nice weekend and happy flying :wink: