No ILS data outside of US

I’m on XP11 and I have updated my navdata to the newest cycle. I tried flying ILS approaches in CYYZ and EGLL, but even with the frequency, altimeter, both courses and everything else I can think of (I did all this in KORD and it worked), I get nothing on the approach screen. Programming the ILS approach into the FMC also does nothing. Is this a bug or an issue on my end?

Specs: XP11, Zibo 737

Hello, do you mind sending us a screen shot of this?

I assume an issue on your system. I have tried to reproduce it but I receive in both your examples the loc signal.

Delete the data in ‘custom data’ folder and look if you receive a signal than. When yes, re-install the cycle in this folder and try it again.

It should work because I can’t reproduce it, nor have we received any other report to this which would indicate a general issue, sorry.

Let us know the result please.


I’ll try the fix in the morning. When I open the X-Plane map, there aren’t any localizer icons/glide paths for airports outside of the US if that clears anything up.

Allright, thanks - additional try to run the X-Plane installer. Possible you miss a file or a file is corrupt. With the installer you must see the ILSes again because it uses the stock data then.


Thank you so much! Looks like deleting the entire Custom Data folder, validating files, and reinstalling navdata from Navigraph worked! The ILS icons are now back on my screen!

Great - good it is working again - good job!

Have a nice day,

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.