No Charts within QW 787 (Latest Update 1.4.0 currently installed) P3D V5.1

I decided to post a bit more detail about my steps and what is (not) happening in the sim.

MS AntiVirus is completely turned off

MS Firewall also completely turned off

I only use Charts within the Planes (QW787) and online via the ultimate subscription.

Currently, since yesterday I noticed this, I can not see any charts on the planes EFB´s

The pages stay blank (like white paper) in QW 787 and the authorization Pop-Up does not show anymore in QW 787 (probably bad requests??).

This morning

  1. uninstalled the 787 V1.4 via Programs/Features and deleted ALL left overs in ROOT and elsewhere. Incl. License, etc… Restarted my PC afterwards

  2. Installed the 787 V1.4 again (in Root as per installer suggested, not changed anything here)

  3. Before #2 Checked if the the file navigraph_auth_status.dat was deleted, which I did manually before installing it again! It was. Just to be sure(which containt: status=auth_success)

  4. Before #2 Checked if the file qwnvgsettings was deleted. Which I did manually. It was (which containt:[navigraphOIDC]

refresh_token=f88d61f2d583**************

  1. Used P3D´s “Delete generated file” and started the sim

  2. Took the 787-10 QW RR Model

  3. Went directly to the EFB without planning or changing anything (with complete STOCK QW787.CFG). Turned on external power

  4. Clicked on terminal charts

  5. Put in START: EDDF and DEST: EDDM. Clicked “complete”

  6. Clicked on “navigraph” right down corner

  7. No POP Up showed up with the normally needed Authorization for using Navigraph

  8. Also I noticed that normally the EFB Charts names from QW would normally switch to Navigraph ones (Names in the grey boxes would switch), they did NOT in this case

  9. Clicking on any grey box would show a blank white “page” with nothing on it

  10. Selected the QW charts again (Down right corner)

  11. Selected an QW chart, works fine

  12. closed the Sim

  13. Checked the P3D Root directory if the files from #3 and #4 would have bin generated. This is not the case

So it seems the “1.4” EFB is not able to “pull the authorization” pop up.

Doing this manually by running the “QWNavigraphOidcClient” app as an ADMIN does bring up the pop up. After granting access the files as named at #3 and #4 are generated in P3D Root directory. The files do contain the needed token and needed status. The files date and time matches with the time I ran the “QWNavigraphOidcClient” Application manually.

But starting the SIM directly after this does not change anything in the EFB regarding the blank Navigraph pages.

Important EDIT:

Could the problem be on the Navigraph Side (API issues?). I have found some users who are stating that the Desktop Chart App is also showing blank pages. Online Charts, which I use via the WWW, do work properly. But they say desktop app shows blank pages.

I do not use the Desktop App, but I thought this could be a Hint to you to Check over at Navigraph if they have an issue with the API you are using.

Quote from another user:
As the title, the Navigraph chart source not working. Even did not show out any window or website as other topics. I tried to use Fiddler to monitor the connection action, then found the request got a 400 HTTP response like following:


HTTP/1.1 400 Bad Request

Content-Type: application/json; charset=utf-8

Date: Mon, 08 Mar 2021 16:17:39 GMT

Server: Microsoft-IIS/10.0

X-Powered-By: ASP.NET

Content-Length: 27

Connection: keep-alive

{“error”:“invalid_request”}


the request data pack like following:


POST https://identity.api.navigraph.com/connect/token HTTP/1.1

Connection: Keep-Alive

Content-Type: application/x-www-form-urlencoded; charset=utf-8

User-Agent: cpprestsdk/2.10.1

Content-Length: 139

Host: identity.api.navigraph.com

grant_type=refresh_token&refresh_token=&code_verifier=&client_id=charts-qualitywings-b787&client_secret=*************************


will these help you guys to find out the problem and solution? looking forward to your suggestion.

My sim is always used with ADMIN rights.

Hi,

The QW EFB charts implementation has been developed by QualityWings, and we have no insight into the source code or what has been changed in the latest release. We have not changed anything on our side that should have any effect, and we don’t see any reports that you claim that the Desktop app is showing blank pages. (Our forum has no such reports so we can’t really check that, so I suggest you tell those to post here.)

The Desktop app and the web app (Charts Cloud), as well as all third party EFBs, use the same API and backend. If it works in Charts Cloud it should work also in your EFB and Desktop app, from a Navigraph API and chart delivery perspective. And also that should indicate that your firewall isn’t interfering the the API requests. Perhaps you have a firewall or Antivirus blocking the simulator or QW addon from making web requests?

I’d suggest you to contact QualityWings and ask them for support as we don’t really have insight into the code, but from our end everything seems normal.

Regards,

Stephen

Update: We checked our logs for the authentication flow, and it seems like the error “Refresh token is missing” is given, and this is because an important parameter seems to be missing in the call to our servers. You should report this finding to QualityWings.

Hi Mister Stephen,

many thanks for your outstanding quick support and finding a possible cause. I will parse this to the QW developers.

Many thanks again!
Marcus

Good to hear!

Regards,

Stephen