Navigraph MS2020 Missing APR Waypoints

Hi and Thanks works perfect now!

My only wish would be 1 or 2 more Zoom Level on the Topo Map to see where i am exactly and what is called what ( lakes , towns sightseeing :))

1 Like

But wait here is one Waypoint Missing (EDDG EDXW ILS 32.

OLDIP is Missing

That is odd indeed, but I am not sure we can do anything about it. This is the route string that we get from the simulator in this specific case:


As you can see, the Charts panel accurately represents this route. However, I too see that the in-game GPS loads the OLDIP waypoint for some reason, and I will investigate if there is something that we can do to get that waypoint as well.


Alright, upon investigating this issue I realized that we did not properly register the approach transitions from the simulator. The OLDIP waypoint was of course an automatically added transition point and not part of the route itself.

I have fixed this issue, but have not issued another explicit update to the panel. In order to get the updated version, please uninstall the panel and then reinstall it!

Let me know if it works as expected! This is what it looks like for me with your route now:

Kind Regards,

Edit:Now often i get Destination Runway not found error in IFP.

Still not fixed i get a diffrerent FP at the End of the Flight:

After KULUD comes ESTA then VAPUB then PRELAB and so on:

There are a multitude of things that might cause this, let me investigate and I’ll get back to you!

Everything looks correct here, not sure what you mean. On the GPS, you see that the flightplan stops att ESTA, the ICAO identifier for your destination airport. What follows is a separate section (labeled Approach - ILS 14 Z, that contains the waypoints that should be used for the approach. In your screenshot, these are VAPUB PELAB FI14. This section should be included before the destination airport, but to make the flightplan easier to read the GPS shows these waypoints in a separate list.

If you look at the charts, that is exactly the route that is shown, with the exception of the FI14 waypoint which would be located somewhere along the start of the last orange dotted line (not needed for the charts, only in the flight computer).

Let me know if I misunderstood your question and thank you for the feedback!

Kind Regards,

This is what the imported flight looks like for me. In the world map, I selected IFR Low-altitude, EDXW to ESTA and Direct for both departure and arrival. I then selected the ILS 14 Z approach and loaded into the simulator.

Also, please make sure that you have the latest navdata (2109) installed in the simulator as the panel is currently running that cycle, and by the looks of your screenshots I can tell that your simulator is still calculating the route based on old navdata.

Regarding the “Runway not found” error - it should have been fixed now. Please verify by reinstalling the package through NNC again!


Hmm cant you see this? or cant i :smile:


In Navigraph the Orange Long Line is going to Halmstad ESMT way to much north, and then it goes back to PRELAB.

In MSFS and the G1000 its going (of course because why fly north then back) ,after PRELAB, directly to the runway.

Screenshots where made with AIRAC 2109 rev.1

That does not look like what I get. Could you export the flight from the world map so that I can be sure that we use the exact same flightplan?

This is what it looks to me:


Here its going to Halmstad then the green XIRTH2H Leg, then back to PRELAB

Looks like a bug to me. The MSFS flightplan, as drawn in the world map, represents what it should look like without an arrival/STAR selected, yet you have selected an arrival. Please select this dropdown and choose “direct”, not XIRT2H:


For reference, this is what the arrivals to ESTA look like. The Charts application seems to be doing the right thing:

Yes, what i do is:

EDXW, ESTA, IFR LOW, then press ILS 14-Z (that generates a NILE2H 14 Arrival but even without it its not going to HAMSTED.


Heres the Plan with Direct:

ESTA-DIrect.PLN (5.1 KB)

Loading any of the flightplans you have uploaded will automatically select an arrival. The simulator incorrectly visualizes this, but it is clear if you look at the top menu only.

  1. The selected arrival shows XIRT2H.
  2. The map should show the XIRT2H arrival, but it does not. Refer to my previous post for a look at how the arrival actually looks.

i know but the only problem is that navigraph goes to HAMSTED , this is not correct.

Hmm i get this error when Navigraph loads the FP in:

it dissapears very soon after like 3 seconds.

Did you reinstall the panel? That has been fixed, I do not get that error when loading your flightplan.

This is what I get when loading your flightplan:

And this is what I get if I explicitly select “Direct” from the arrivals drop-down menu:

What is not correct exactly? The fact that the route goes to HALMSTAD? That is entirely correct, as you have selected the XIRT2H arrival. The first waypoint in that arrival is located exactly there:


ok i deleted it again in the community Folder, then reinstalled via Data Manager, same Error same Problem: This is direct without Arrival:

I will re-publish the package in a bit be 100% sure that the new version is available, but the “problem” is still not a problem as far as I can see? Do you agree that it looks like it tries to go from the last WP in your flightplan directly to the start of the XIRT2H arrival?

Here is the latest version, double checked and working on my side: (39.7 KB)