Navigraph Charts on web

Good day all,

For several days, randomly, the NAvigraphe aeronautical charts site has been experiencing malfunctions (or even screen here 2023-11-16 14_51_38-Navigraph Charts.jpg - Google Drive). This service is paid and for a fairly high amount. We have the right to expect reliable service. I am therefore waiting for a commercial gesture intended to compensate for the lack of service.

Hello, welcome to our forum! Thanks for reaching out.

That’s why we have our forums, where you are welcome to post any issues that you come across. In this case, this is not a general issue as is evident by the fact that there are no other similar ongoing topics! We will do our best to figure out why this is happening for you!

Are you able to reproduce the issue? As in, are there any particular steps that you take before that message appears? This information would be greatly appreciated.
That screenshot you sent shows what appears whenever something goes wrong that we did not anticipate, and it is highly likely that it is caused by local factors that are hard for us to reproduce.

I have turned on some additional logging for your account. If you see this issue again, please post an update in this thread and we will take a closer look with the help of this data!

For now, please help us out by providing:

  • OS
  • OS version
  • App version

Apologies for the inconvenience, and thanks for reporting this so that we can look into it!

Kind Regards,

Good day sir,

here are the answers to your questions :

Are you able to reproduce the issue?

This problem occurs randomly, without regularity but every day

As in, are there any particular steps that you take before that message appears? This information would be greatly appreciated.

No prior information, this screen appears as soon as I open the application or web page



APP VERSION : 8.30.0

Thank you for your intervention.

JF Godel

Thanks for the update!

Have you seen the issue since your last post? We don’t have any logs from your account yet :thinking:

Now that I know that you are on Windows, please follow these additional steps:

  1. Press Win + R
  2. Type %appdata%/Navigraph Charts/logs and press enter
  3. In the Explorer window that opens, locate the main.log file
  4. Upload this file to your next post

This way we can hopefully gain some more insights into what has been happening for you!

Kind Regards,

Today, no problem with application.

Attached, you will find the requested log file.

Thank you sir.

JF Godel

main.log (73 KB)

Thank you for the log file!

It seems like your installation got corrupt. The logs indicate that a coordinate used somewhere in the app was unexpectedly given a latitude value of either less than -90 or more than 90.

It is hard to tell exactly how this happened and where, but it is not unlikely that just reinstalling the application helped get you unstuck.

If you come across this issue again, please let us know! And in the meantime, following these steps will likely get you un-stuck again:

  1. Exit Navigraph Charts if it is running
  2. Press Win + R
  3. In the dialog that opens, insert the following:
cmd /c rmdir /s /q "%APPDATA%\Navigraph Charts\Local Storage"
  1. Press enter
  2. Start Navigraph Charts

I am happy to hear that it is currently working for you! As mentioned, let us know if that changes.
In the meantime, I will mark this topic as solved!

Kind Regards,

Good day sir,

Thank you for all this information which I note well, your intervention and your responsiveness

JF Godel

1 Like

Good day sir,

The incident occurred again today when displaying the map page at 1:50 p.m. I attach the log file. I’ve dowloaded latest version and installed again. But today, even after installing the latest version, it doesn’t work.

Thank you sir.

JF Godel

main.log (81.4 KB)

I add that I use two PC and that I encounter this problem on both PC.

JF Godel

That is interesting! I see that we had some issues with our extended logging, please sign out and then in again and let us know when the issue appears again!

Sorry for the inconvenience, we are still not able to track this down just yet.

Good day,

This morning again, impossible access to the navigraph maps page. Attached log file.

Thank you.

JF Godel

main.log (110 KB)

Hi! Thanks - we now see your detailed logging on our side as well.

It appears that Simlink is getting crazy values for your position from your simulator. Which simulator are you using? And have you updated the Simlink app to the latest version?

Kind Regards,

Hi JF Godel,

Thank you for the Charts log file, and from the investigation it looks like there are some wrong data received into the SImlink application.

For more details on the issue, please send us Simlink log files which are located at %APPDATA%/Navigraph/Simlink/logs

And one more check, can you please reinstall the Simlink Plugins to the flight Simulator by using the Simlink application?
NOTE: In the case of the MSFS flight Simulator, you do not need to install Simlink Plugins.

Please feel free to inform us about any issues.

Kind Regards,

Vishal Ahir

Goo day Vishal,

I am attaching the SIMLINK log file. I reinstalled SIMLINK a few minutes ago. I am attaching the screen of the “Plugin Status” window created a few minutes ago.

Thank you.

JF Godel

FSX_20231122121435_log.txt (191 KB)

2023-11-22 17_12_14-Navigraph Simlink Status.jpg

HI JF Godel,

Thank you for the more details about the Simlink installation.

From the screenshot, it looks like there is some wrong with your FSX flight Simulator.
Simlink detects two versions of FSX. So if you are using the Steam version of FSX then there are some old FSX version garbage registry exist in your Windows OS.

But we can correct the Simlink settings for Flight Simulator.
Can you please clean up the Simlink configuration by this? After the clean up please reinstall Simlink Plugins.

Please feel free to inform us.

Kind Regards,

Vishal Ahir

Good day Vishal

You wrote to me: “Can you please clean the Simlink configuration by this?”. But how should I proceed to “clean Simlink configuration”?

I have to be away from home until December 4th. I will no longer have access to my desktop PC but only to my laptop.

Thank you.

JF Godel

Hello again! With the recent release of 8.32.0, we have updated the Charts application to make sure that these kinds of issues do not prevent the app from functioning. Thanks for the feedback!

I note that you wrote this through an email client. Perhaps you did not notice that the word “this” in Vishal’s sentence was a link. If you follow this link, you will find clear instructions on how to proceed.

In fact, I am quite sure that you are on a Windows PC. In that case, I can link you directly to the related instructions! You can find them by following this link: Navigraph Simlink sign-in - #10 by vishalahir

Kind Regards,