Nav data not uptodate

Dear Navigraph, I just reinstalled XP11 and attempted to install NAV data. However in the fmc it says the data is from 2018, some help would be much appreciated.


Are you still running on MacOS? Have you installed FMS Data Manager for MacOS ? What steps have you taken to install Navdata update?

Some screenshots would help using Guide to posting Screenshots


I have FMS Data Manager for MacOS installed, these are the screenshots of the navdata steps and installer.

I note your Addon Mappings tab show Manual. Please select and remove these.

Please post a screenshot of your X-Plane path in the Settings tab. Check this is where you X-Plane app is located. If not, navigate to where it is and Save.

In Addon Mappings tab press Scan and you should find your three entries are detected automatically. Press Save.

Hopefully you can select and update these in Addon List tab.


This is the path, should it be going the whole way to Custom Data?

The X-Plane path you show looks correct. In Addon Mappings , Scan should correctly detect your addons. If not you will need to add them manually using +Add.

After updating and restart of computer, please post screenshots showing dates in the FMC.



Download full-resolution images

Available until 24 Aug 2022

](iCloud)Hi, I’ve tried all the suggested steps but none have proven successful. Below are images of my FMC and current data paths.

Which aircraft/addon do you use here? Is it the in-game XP11 B737 or what type of a/c is it?


It’s the level up 737 for Xplane 11

The Zibo and LevelUp both use default X-Plane aircraft FMS Data.

Please post a screenshot of the default X-Plane B737 Status page using Guide to posting Screenshots rather than full screen which is harder to read :

Please post screenshot of the following:


Still no idea, sorry!

In the Addon List tab make sure you select your items and press Update.

You should see Installing dialogue in the status line below:


All fixed, thank you so much for the patience and speedy responses! Turned out that the XP11 data was going into the wrong custom data folder.

1 Like

Hi Malachy,

You are welcome. Glad it is resolved.

Happy flying.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.