MSFS SU10 places custom waypoints at the north pole when Navigraph navdata is active

Hi, I reported a bug on the official MSFS forum about custom waypoints being broken when loaded from .pln files in SU10.

I got the advice to try without Navigraph, and, indeed, as long as no Navigraph navdata is active, the custom waypoints work fine. I tested with cycles 2207r1 and 2209r1, with .pln files created using LNM as well as using the in-game World Map.

I would like to know whether this is a known issue at Navigraph headquarters (or whether you can reproduce the issue), and whether it’s a problem that can be fixed by Navigraph by releasing a revision to the cycle, or if the underlying issue needs to be fixed by Asobo.

Hi,
please can you upload such flight (pln file) that we can try to reproduce it?

I’m not sure what you mean with custom waypoints? Where do you create such waypoints and for what reason?

Thank you
Richard

This flight plan was created by a MSFS forum mod using Little Navmap:
VFR Ninoy Aquino Intl (RPLL) to Iba (RPUI).pln (2.9 KB)

This flight plan was created by me on the in-game World Map:
test_custom_waypoints.PLN (1.8 KB)

The MSFS UI calls user-defined waypoints “Custom waypoints”. Both in LNM and in the World Map, they’re created by adding arbitrary positions on the map (ie. positions that don’t represent an aerodrome, navaid, or fix) to a flight plan. Why? For example, sightseeing.

Hi again,
thank you very much - I can reproduce it but I´m pretty sure, that this has something todo with the SU10 beta. I have now tried to load your uploaded flightplan in the current sim version 1.26.5.0 and here I see the correct loaded path:

loaded with the current version 1.26.5.0:

In both version, I have installed the same AIRAC cycle 2209 - so it looks more a bug in the SU10 beta somewhere. Normally, when you load a PLN file in the sim - it´s independent which AIRAC cycle you have installed because all the user-waypoints comes directly from the PLN file and these waypoints shouldn´t be checked against the cycle.

Again, I can´t explain why this doesn´t happened when our package is not installed - possible that we must compile our package against the SU10 tools, which was not the case here because we don´t support any beta - but it really looks that there is an issue in the SU10 beta with such waypoints.

As soon as SU10 is out and we can compile it against these version, we will try to make another test. But I´m pretty, pretty sure, that this has nothing to do with our data. It´s working as expected in the current version with our data and the navdata schema wasn´t changed between SU9 and SU10. So the only open point is the data compilation which was done with SU9 and not with SU10.

Cheers,
Richard

Thank you for looking into this. I agree with your assessment that the issue is most likely related to changes in SU10, and is probably just triggered by the presence of the Navigraph navdata.

Can I quote your response on the MSFS forum?

Maybe there’s a chance that it’ll be fixed before SU10 is released (or in a hotfix for SU10), mitigating the impact on people who frequently switch between airliner ops (where Navigraph shines) and bush flying / sightseeing / community flights (where custom waypoints are often necessary).

Yes, of course …

Now after a few additional tests - I´m now 100% sure, that this is a sim bug in SU10 beta.

Store your planned flight with custom waypoints NOT in the PLN format, store in in the FLT format. The sim creates both versions (FLT and PLN). Now, when you load the FLT file, all is good - do you open the PLN file you see the issue.

So, it´s definitively an issue with PLN files, in combination with custom waypoints. That has nothing todo with us - can only be fixed by MS/ASOBO - sorry for the bad news.

Hope that helps,
Richard

1 Like

Opened a question in the MSFS developer forum about this:

Will come back, as soon as we get an answer from MS/ASOBO …

Cheers,
Richard

1 Like

I installed the new Airac 2209 rev2 and the problems have been solved.

Cheers,
Fabio

Thank you very much for the feedback Fabio!

Have a nice flight and enjoy the sim :wink:
Richard

1 Like