MSFS G3000 plugin constantly asking for re-authorisation

Please only mention one issue per topic so that others can easily see what has been reported

What I expected to happen.

Clarify your expectations. It’s easier to understand the anticipated
behavior and determine whether it’s truly a bug or a usability issue that
needs to be reviewed.

Attempted a Simbrief flight plan import in the FlightFX Vision Jet. Was asked to authenticate my Navigraph subscription at Navigraph using the provided code. Having done this previously, once completed, you can re-enter the ‘Simbrief’ section of the GTC MFD and pick a flight plan to request / import. This has worked for me previously.

What actually happened

Please describe what happened in a way that enables us to find the problem
without follow-up questions. For instance, saying “the charts do not work”
or “login is broken” doesn’t help. To the extent that it is possible, please provide clear steps to reproduce the
problem. Screenshots and error messages are helpful and encouraged!

Having authorised the VisionJet against my account, and having been returned to the GTC MFD menu, I clicked ‘Simbrief’ again, and was asked to authenticate again. I did so. Then I was asked to authenticate again. And again. This continues in a loop forever until I re-start the simulator (re-starting just the flight does not fix it). Authorisation completed successfully each time (per the Web site).

This has happened to me twice now. The common factor is that it was the G3000 in the FlightFX Vision Jet both times.

Hello, welcome to our forum!

I have a couple questions:

  • Which platform are you on?
  • Are you running the latest version of the Vision Jet?
  • Which version is reported in the Navigraph Settings in the GTC?
  • If you are on PC, do you have the Navigraph Avionics plugin installed?

Kind Regards,

Hi. I’m on PC. I am using the latest version of the Vision Jet. I do have the avionics plug-in installed, and it’s worked fine up until now.

To give you the version number from the GTC I will have to boot up the sim which I can’t do right now but I will edit this post and put it in when I can.


1 Like

When did it stop working for you?

Sounds good, no worries!

It happened once on Sunday and again yesterday.

I have a feeling in both of those instances I had restarted the flight after problems. But I can’t swear to it. I will try to test that scenario again.

Version in GTC is 1.2.5

Thanks for confirming! That sounds like the latest version indeed.

I am not able to reproduce this issue myself, but I am using an older version of the jet provided to us by FFX. We will contact them to ensure we’re on the latest version, and I’ll try again!

If you find a way to reproduce it every time, please do let me know! Do I understand correctly that the flight had been restarted just before the issue occurred in both the mentioned cases?

Kind Regards,

That is my recollection, and I should be able to get some time to test that later today.

1 Like