MSFS G1000 Keeps wanting Authentication

Hi, all of a sudden i have to enter a code into the G1000 everytime i either start a new flight or start the sim. Its been running fine up till now. I’ve not added any new addons for quite a while.

I have tried a few suggestions where others have experienced the same problem. Checking that time and date is correct. Uninstall and reinstall the Navigraph components. None of these worked. I even resorted to deleting he foders in my profile (Local and Roaming) and in Programdata - Reinstalling the Navigraph components - none of these worked either.

Only other thing of note, when i end a flight or start the sim, the reference in devices on the navigrapph website disappears.

Thanks for your assistance

Hello! Welcome back.

We have checked our servers and we see an unusual amount of sign-out requests from your avionics plugin. We have yet to narrow down the cause of this, so please bear with me while we take a first step:

  1. Open http://localhost:19999 in a browser while the simulator is up and running
  2. At the bottom of the list that appears, click the link containing the word AS1000_MFD
  3. In the interface that appears, select the “Console” tab located along the top of the screen

You should see something like this:


The errors at the bottom are expected, but I am interested in what yours looks like!

Kind Regards,

Hi Malte,

Thank you for responding. The large number of logins is to be expected, I’ve been logging in numerous times… so I dont think thats anything to be alarmed about…

As requested, this is the output from what you asked for:

We are not concerned with the logins, we’re concerned with the amount of logouts. We see an anomaly where your account, specifically when using the avionics, is often calling our servers requesting a full signout. Nothing in those logs points to such behavior, so this is puzzling.

Did you have to sign in after taking those screenshots?

Yes, as soon as I had approved the code, I escaped and went back to main menu, started a new flight and it immediately requested authentication. I’ve just done it again, new flight, approved the code request, escaped, new flight and it requested re-authenticaiton - FYI this was at 1431hrs BST if that helps.


That’s odd. I’ll try to build a custom version with more logging for you as soon as I have time!

That would be great.

Please try with this version: (314.0 KB)

Just follow the same steps :slight_smile:

Hi, Thank you. I’ve added the new module and tried again. I’m afraid its the same result my end. Auth the G1000, esc and end flight, restart the flight and asking for auth again. This was between 1927 and 1945hrs BST.

Also tried a full sim exit and restart, same result again. I ran the localhost link again when in the sim and captured the console output - i can post here if you need that.

Thanks again for your support to try and resolve this.

Yes! Sorry, I was probably a bit unclear - the console output is what I am interested in. I do not expect the behavior to be any different!

No problem, Here is the output from yesterday

Hmm, that can’t be right… Make sure that you install the correct version of the package, here is what the log should look like:

Yours is missing a whole bunch of information for some reason. Could you try hitting the “Refresh” button in the top left of the interface, just above the “Network” tab?


Ok, ill double check. I’ll post results as soon as I can

1 Like

Here we go… I think this is more like what you were hoping to see.

Yes, that is much more interesting! Only the first screenshot, the second is unrelated.

What timeframe are we talking about in the first screenshot? Have you just started the flight and then opened the console?

The screenshot was taken after I had authenticated the G1000… perhaps 10-20 seconds after that point. I dont know if related, but with the sim running and refreshing the console readout, it caused a CTD of the Sim… which I very rarely see happen… thought I’d just point that out. On restarting the sim, it asked my to log back into the Xbox app… which I’ve not seen before.

Here is another screenshot - this is about 3 mins after authentication of the G1000 and doing a couple of flight plan imports…

And finally, If i refresh the console, the G1000 immediately reverts back to the authentication required page.

Interesting. The “bad request” messages in red are what’s interesting about your first screenshot - they are unexpected. Unfortunately, it is very hard for us to trace this issue, and as you can tell by the CTD this debugging experience is not great.

As developers we get used to it, it is quite common when using the refresh button, unfortunately. I have never seen the XBox sign-in when restarting it though! :sweat_smile:

These logs look completely normal! The only errors I see there are from the avionics themselves, not from our plugin.

THAT is definitely not expected. The authentication should never have to be made more than once during the same flight - regardless of how many times it is reloaded. This is very peculiar and it points to something being broken with your simulator installation. The sim can sometimes have a hard time remembering things across restarts, but maintaining the storage within the scope of a single flight has never been an issue…

What does your simulator installation look like? Are you running a beta version? Are you using the Steam or MS Store version? Have you made any modifications to the filesystem of the installation, such as moving the location of the community folder?

Kind Regards,

The simulator as a whole has been rock solid from the day i first installed it last year. Its a full Premium MS Store version with all updates installed as and when they have been released. I do use the add-on manager FS Linker which points to default Community folder. When I first had this issue, first thing I did was to stop all addons via FS-Linker and try putting the G1000 plugin directly into the community folder - but resulted in the same problem.

I"m somewhat hesitant to attempt a reinstallation of MSFS… trying to get rid of all references on the PC is a tough job, with no guarantee of resolving the problem.

I’m certainly no expert, but it would almost seem as if its a permissions issue as in the config is not being saved on exit.

A further update. I’ve just installed MSFS on a different PC. Installed the WTT G1000 add-on, installed Navigraph Hub and the G1000 add-on and the nav database and thats it. Started the Sim, did the initial authentication. Exited to main menu, started the flight again, exactly the same result as on my other PC.

I can only conclude from that its either the Navigraph account which is the problem or the profile for MSFS itself in the cloud. I’m somewhat hesitant to delete the MS profile as I’ll loose all my controller settings and progress.

Is it possible for you to create a temp account which I can try ?

Another update… I completly wiped my PC today. Fresh install of Windows 11 and MSFS 2020. As before, installed the Navigraph updates and the WTT G1000 NXi add-on. Exactly the same still… on fresh install.

Not sure what to make of this now. I’m failing to see where this could be a problem from my end with completely fresh install