Loading ILS into Flightplan issue

Hi all,

I am using the FBW Experimental version, and have Navigraph installed. I am able to load SID/STAR plans without any issue, as well as select the ILS approach in the MCDU, however when I review the flightplan, the ILS is always missing. The navdata simply leads from the final STAR fix to the runway threshold with a discontinuity inserted inbetween. I have tried this with dozens of airports. The interesting thing is that VOR approaches and RNAV approaches work without any issue. I have tried to uninstall Navigraph/FBW to no avail.
Any help would be greatly appreciated please.

Thank you!



Please provide screenshots showing the issue using Guide to posting Screenshots.


Hi there,

Of course, please find screenshots attached.
As you can see, I set up a basic flight plan from EGLL-EDDH with the STAR RIBS6A/ILS 05 approach.
When I load this, the STAR loads, but after the final point of the star, I simply get EDDH/05 and no centre fix or final approach fix.#

However when I load the ILS without the STAR, it loads without any issues.
Finally, if I use a VOR/RNAV approach this also works without any issues. The ILS data does not seem to be loading with the STAR data.

I have tried uninstalling and reinstalling both FBW and the NavData.
Any help would be greatly appreciated!

Does loading the ILS05 with VIA DH257 give what you are expecting?


Hi Ian,
Thanks for getting back so quickly.

I can confirm that this happens with all airports! I’ve tried several scenarios in different locations with different arrival procedures and the issue is always the same - the ILS will not load into the flight plan when connecting it to a STAR, however only proceeds to do so separately. Very confusing as this has never happened to me before.

Also realise I didn’t answer your question - no, it does not. As soon as an ILS is selected with a STAR regardless of transition, the ILS waypoints disappear.

… hi, sorry when I also take my hand in this topic - but you wrote, you´re using the experimental version of the FBW - have you tried it with the stable version (or at least dev version) too? Because experimental, means experimental and it´s hard for us, to give you a qualified answer (or in best case a solution), when we don´t know what the experimental version does exactly.

I mean, it must not be a navdata, flightplan issue it can also be simple a issue in this version. Also, have you tried it with any other aircraft too because I´m not 100% sure, if the ILS information can be set via an external flightplan (only a assumption - without verified it).


Very strange issue - I downloaded the Dev version and it seemed to create no issues! Then reinstalled the experimental (despite having reinstalled the experimental yesterday), and it seemed to fix the issue.
Excellent spot! I suspect the bugs floating in the Experimental version need to be ironed out and caused various issues…
Many thanks