Installation trouble

Hi there,
I have some problems installing data in MSFS2020.
Everything seems fine in the installer

but then in content manager this is what I see, no version, no Navigraph logo:

In the simulator alll the nav data is missing, either in the flight planner and the fms, I mean no airways, no fixes, no sids/stars etc.; when I uninstall Navigraph data default nav data is present.
I swear I read all the faq and installation guides :sweat_smile:, tried uninstall/reinstall several times, deleted Content.xml file.

What went wrong?


Hi Gaetano,
please can you upload your content.xml file. Do you use any addon linker or similar else?

A post was split to a new topic: Why don’t you change the AIRAC dates in the FMC

Hi Richard,
first of all thanks for the quick reply.
Here is my Content.xml from the AppData/Roaming folder.
I don’t use any addon linker; actually I should say that I installed ModManFX, but I’ve never used it.
I have only the FBW A320 mod, a bunch of liveries, the Garmin G1000 and G3000 mods, and a small scenery mod installed, all by manual copy in the community folder.
Can I ask what the Navigraph Navdata installer does, or it’s developer’s secret? :smiley:
It just copy data in the community folder and disables fs-base-nav through Content.xml?

Thanks again!

Content.xml (3.6 KB)

Hi again Gaetano,
thank you very much for the content.xml file - looks good so far. One additional question, or more two more requests:

  1. Can you upload your UserCfg.opt file (it´s in the same location as the content.xml file)
  2. Are you able to make a screenshot of your community-folder please, that I the installation path of our package?

The reason is for that is, the installer looks perfect, means you have installed the correct installer version and the current AIRAC (revision) but it looks very strange in the “Content-Manager”.

As an additional test:

  1. close the sim (if open)
  2. close the Navigraph installer (if open)
  3. delete the “navigraph-navdata” folder in your community-folder manually (via explorer view in windows) - the complete folder, not only the content in this folder
  4. open the Navigraph installer (now you should see no AIRAC installed) and press install
  5. look again via explorer in your Community folder if the “navigraph-navdata” folder is re-created
  6. start the sim and look into the “Content-Manager”


I tried the test you suggested but nothing changed.

Looks like to me that something is preventing the sim to access the files inside the folder navigraph-navdata; indeed I tried to delete the content of that folder and I got the same result in the content manager, no version and no Navigraph logo.
Then I had another idea, delete Content.xml, and simply rename the folder to navigraph-navdatax… and boom, everything working now!!! :flushed:
So, for some reason, the sim can’t access the content of a folder named navigraf-navdata, or that’s what it looks like. :thinking:
Anyway, I uploaded the file and the screenshot as you requested, if you have any hint it’s good, if not just don’t worry, I’m fine with the situation now, maybe I messed up something and a complete reinstall of the sim would solve this.


UserCfg.opt (3.3 KB)

Hi again Gaetano,
looks very strange and I will try to explain why?

When the sim starts, the sim reads the sub-folder in the community folder automatically and add every sub-folder to the content.xml file. So, when you add the x on “navigraph-navdata” folder, you should see these packages also in the content.xml file. The sim doesn´t currently clean-up the content.xml file, means when you delete a sub-folder from the community-folder, the line is still present in the content.xml file.

So, it looks like, that you sim doesn´t read this folder correctly or you have send me the wrong content.xml file but all in all, it´s a very strange effect on your system and I´m pretty sure, that there is any issue here but that has nothing todo with our installer because the installer installs the package into the correct folder (as I see on your screenshot). So something is bad on your system, sorry …


Yeah, I’m pretty sure the installer works ok, as it creates che correct folder, and then the sim writes the correct content.xml (the content file I uploaded here was from before renaming the folder). But then the sim just can’t read that folder. Anyway, as I said before, I’m fine with the “renaming the folder” workaround for now, after all it’s just once in a month or so :sweat_smile:
I’m sure that one day, where I reinstall the sim, everything will work as it should!

Thank you for the support!


1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.