Incorrect ground speed and missing other values in telemetry


Experiensing today :

Flying at 11000 feet, propeller aircraft panel (BARON 58TC ) indicates 186 knts , while your soft indicates Grounspeed 115 knts , which is impossible !

Probably a bug in the soft

Daniel Louis CONVERSAT

(I have some pictures of the screens, but unable to join here)

complement : I will try with other planes

same : on an airliner , passing 26000 feet, climbing , indicated 376 Knts, demanding mach 0,76

the telemetry on Navigraph indicates : Grounspeed 260 knts

Hello! Welcome back to our forum!

Are you comparing the correct values? You say that your aircraft is indicating a certain speed, and you are comparing it to groundspeed which is not the same thing.
Our software has groundspeed, true airspeed, and indicated airspeed available.

The values come directly from the simulator. Which simulator are you using? Could you confirm that you are indeed reading the GS? This can usually be found in the GPS unit in the aircraft, if applicable.

Kind Regards,

I use XP11-50 ; the bug appears in every cases : the groundspeed (I know what it is) cannot be lower than the indicated airspeed at high altitutude

I confirm that the GPS units work well in all aircrafts I use, and also that the arrow on the Navigraph chart woks well also

In the real word, the indicated airspeed decreases with altitude increasing on the aircraft panel, wich is normal, but the groundspeed is always much more than the indicated airspeed

I am a former commercial pilot and I know very well the matter

ALso at low altitude, the grounspeed on Navigraph is about the half of the speed of the aircraft

and ond Navigraph the Indicated Altitude, the GPS Track and the Rate oe of Turn do not work at all

I probably misunderstood you: In my mind, you can easily fly into a headwind and get a higher indicated airspeed than ground speed. That’s where my question is coming from.

What version of Simlink are you using?

Please ensure that you are on the latest version, and also make sure that your Simlink plugins for X-Plane is up to date. You can do this by checking the “Plugin Status” page and uninstall, then reinstall the plugin for your simulator.

This should ensure that you are not seeing any of these issues which have since been fixed:

If you are still having issues, please provide me with a reproducible scenario with default aircraft so that I can take a closer look!

Kind Regards,

Not at all
I adjusted the meteo as CAVOK to have no influence of wind

I have verified all data ; I will see your suggestion concerning the telemetry ; it seems that the problem comes from it ; As I said before, the Indicated Altitude, the GPS Track and the Rate of Turn do not work as well ( and probably should work )

I let you informed

I checked what you said

This is exactly my problem ! How to correct it ?

for info, I use Navigraph 8.34.0 , wich seems up to date ; and because I receive GPS location, Vertical speed, Bank angle , Navigraph is connected to my X-Plane 11-50 ; only the other data, as decribed before, are missing

I just tried to uninstall Simlink and reinstall, but the same bug is always present

I confirm that my Navigraph Charts screen (Telemetry) receives

  • Grounspeed , but totally false
  • Vertical Speed
  • Magnetic Heading
  • Bank Angle

Missing are

  • Indicated Altitude : indicating ------------
  • GPS Track : ------------
  • Rate of Turn : -----------

But in fact, I receive the GPS correctly on the main screen

If you give me your mail, I could send you some screenshot

for confirmation, at the moment, the plane’s screen (an Airbus jet) indicates a grounspeed of 508 knts, while Navgraph charts gives Grounspeed (GS) 261 knts
This is a confirmation of the bug (if needed ! )

No answer from you ; the file is not closed ; I am prepared to send you some screenshot

It can not exist two different Grounspeed in the same flight

apparently, the chapter Telemetry has not be well tested on your side ; It has to be corrected ASAP

Thanks for the screenshot! Don’t worry, I have not forgotten about this topic but I had hoped that a colleague would be able to try this out with some addon aircraft - since I can’t reproduce this with default aircraft.

Here is a screenshot from my X-Plane installation. As you can see, GS is correct!
Additionally, indicated altitude is available along with GPS track and rate of turn.

What you are describing could still be symptoms of running an old version of Simlink! I suggest following these steps:

  1. Open the X-Plane install directory
  2. Navigate to /Resources/plugins and remove NavigraphSimlink_64.xpl
  3. Open Simlink and make sure that the version (bottom right) is at least
  4. Switch to the “Plugin Status” tab and press “Plugin settings”. In the list that appears, the X-Plane plugin should be reported as not installed.
  5. Press the “Install Simlink” button

When done, please try a flight in the default Vision Jet. That way, we know that the aircraft is using the variables that come directly from the simulator and not something custom that Navigraph could not possibly know about. Do you still see a discrepancy?

Kind Regards,

first of all , I had an old version of Navigraph+Simlink, taken from a memory file I had since long time
But trying to call the screen : nothing appened ; just a message that the soft is already open (see image) ; impossible neither to read the version, nor to use it
I suppressed all and make a new download ; after that, same phenomena : same answer that Simlink is already running, but no screen, except the small one informing that the soft is well connected to the different simulator I have : XP 11 and XP 12
But no screen of the nav and the flygt plans as before
instruction to correct , please ?

Now, I changed all by removing and reloading the soft,


It seems that the bug was only a problem of updating

Thanks for your help

Well , correction ; not totally solved !!!

The next day, I switched ON the computer, and I tried to load a plane and a flight , hoping that Navigraph will be connected by pressing the arrow of the main screen

answer of Navighaph : Simlink needs to be running In fact, other screens indicate that Navigraph is well connected with all simulators, and Simlink running

What happens again ? Your system seems a little bit complicated

Remark : I changed nothing between the shutdown of yesterday and this morning ; more surprising !

new trial :

I cancelled all Navigraph+Simlink on the computer ; and I reinstallled it from a recent dowload (to be up to date ) ; result all works well ; except perhaps the weather screen, which continue to indicate “Radar” wxhen I call “icing” , combining radar ans icing on the screen ; is that normal ?

Now, I will shutdown the computer and see what happens in a new sequence : that is to say the stability of your soft ; normally, by wake up the computer, all should remain the same ; I will see and let you informed