ILS 25L KLAX not working (xp12)

Hi, today i was flying into lax on vatsim on the flightfactor 757-200 and could not intercept the localizer I-LAX on 109.90 and a course of 251. I have the latest navdata installed. What should i do?

sorry, for the long delay of your question, I have overread it …

I haven’t the FF757 but I have tried it with the FF767 and the Zibo 737 and in both a/c I see the ILS and the GS coming and intercepting.

Both addons uses the same data as the FF757, so when this would really a data issue, we should see this in other addons too also in the stck C172 with the G1000 equipped.

Is this only happening at KLAX 25L or general?

Can you test this with another a/c, possible with one of the stock aircrafts?

Sorry again for the delay, thank you

It was happening in general with the FF757 and Zibo and Levelup 738ng, which leads me to believe it was a data issue. It seems to be fine now. I’ll test a stock a/c tonight.


Hey Richard,

So i know its not a default aircraft, but I just flew the Zibo 737 into LAX and tuned 109.90 and a course of 251 on both radios and the localizer and gs never appeared nor intercepted. I tried Retuning but it just didnt work.

thanks in advance.

Ok, after testing the default B738 by Laminar, I still cannot see the Localizer nor the Glideslope on my pfd.

be aware, that ILS 07R and ILS 25L has the same frequency 109.90 but with different LOC idents and courses. ILS 07R has IMKZ and ILS 25L has ILAX. Possible this is your main issue and also the main issue that the addons can´t handle this …

ILS 25L:

ILS 07R:

You see, the same frequency but different runways … that´s not a navdata issue, it´s more a addon issue than. The navdata seems to be correct …


Whenever I try to even tune it from as close as 10NM, it just doesn’t even appear at all on the pfd. No IMKZ or ILAX. Just ----/251 degrees.

Hi again Luke, but it seems you have any other issue - I have now tried the stock B737 and here I see the LOC/GS signal

AIRAC 2309 - standard/stock B737, standard sceneries - XP12.05r1:

What you can try is, that you set the navdata back to default and when it´s working, that you update it again:

  1. close the sim
  2. delete the whole content in <your x-plane root folder>\Custom Data
  3. start the sim and try again - when you see the signals also, try to update the data again

Sorry, but I can´t reproduce your issue nor can´t I see any data issue. Again, be aware that 109.90 is a dual frequency for two runways in KLAX, but you should get at least one signal thats clear …


Ok, I’ll try that. Thanks for helping me through all of this!

cheers, luke

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.