I can not login SimLink

Good day!
I can not login SimLink.

When I log SimLink, browser window (Google Chrome, tried to login to Edge, I don`t have antivirus programs) opens and the registration is confirmed - “You’re signed in” but an inscription appears “Try again” in the SimLink window. It repeats itself over and over

I reinstalled everything completely (FMS Data Manager and Charts too) and followed the instructions:

  1. See FAQ - Simlink Install and Systray 29
  2. In Navigraph Simlink Plugin Settings, for your FS entry press Uninstall Simlink.
  3. Use Windows to uninstall Simlink.
  4. If they exist delete folders c:\Users\username\AppData\Roaming\Navigraph\Simlink and c:\Program Files\Navigraph\Simlink
  5. Download and install latest Simlink (Navigraph).
  6. If still an issue please zip and upload all in c:\Users\username\AppData\Roaming\Navigraph\Simlink

FMS Data Manager and Charts work fine and login without problems.
SimLink previously worked without problems too.

I don’t know what`s happened.

With best regards, Andrew.

Hi Andrew,


Please post a screenshot sowing the error message using Guide to posting Screenshots

Also please zip and upload all in c:\Users\username\AppData\Roaming\Navigraph\Simlink.


Hi, Ian!

Simlink.rar (20.9 KB)

We are investigating. Please confirm your computer’s time is correctly set.


I fixed problem with my SimLink . Time synchronization has been disabled in the Windows “date and time” settings. When I turned it “on” SimLink started working.

Hi Andrew,

Glad it is resolved.

Happy flying.