Graphic Glitches

Hi!
Since the Dispatch has been upgraded I’m getting graphical glitches once I generate the flight plan. It’s a Chrome related problem, as it doesn’t happen in Firefox, and it’s not related to Hardware Acceleration.

It happens ONLY when I generate the flight route. Not before.

Hi, this is not related to the recent update. It started happening during the previous version as well.

Since this only started happening a few days ago, and the previous version was out for many months before this started, I am suspecting some sort of bug in Chrome, Windows, or perhaps the graphics drivers. Something specific about the Flight Briefing page seems to trigger it, but I still suspect the actual bug is outside of SimBrief.

It seems to affect a small number of users at the moment, possibly limited to a specific Chrome/Windows/Graphics card/Driver combination. I can’t reproduce the issue on my end, so it’s very difficult for me to come up with any fixes or workarounds I’m afraid. If I could at least reproduce it, I might be able to figure out a way to prevent it from happening on this page.

Chrome has a history of having similar bugs in the past, so perhaps this one will also be fixed shortly. We will continue to keep an eye on it and try to think of possible fixes or solutions.

Some ideas you could try to see if it makes a difference:

  • Toggle the “Small Map” setting from the upper-right menu (3 vertical dots).
  • Once the small map is enabled, hiding the map completely using the icon to the top-right of the map.
  • Resize your browser window to see if the issue goes away at smaller window sizes.
  • If you are using multiple monitors, try disconnecting the second monitor so that you are only running 1 monitor.
  • Try temporarily setting your screen resolution smaller to see if that fixes it, the issue seems to affect more users with 4K screens for example.

Let me know if any of that helps, maybe it will give us some other ideas we can try.

Cheers,

Did I also understand correctly that you’ve tried disabling Chrome’s graphics acceleration with no effect?

If not, please try disabling this in the Chrome settings and restarting the browser:

It will make the page run slower, but I’m curious to know if it fixes it.

Best regards,


this seems to have fixed at my end

2 Likes

Thanks for the info! Hopefully it will be helpful for the others as well.

1 Like

Yep, that absolutely made the trick. Thanks soooo much.

1 Like

Thanks for this Sir. It seems to have fixed the problem. Great help. Appreciate it.

1 Like

Just to follow up, I have released an update that I think might prevent this from happening (without needing to use the Small Map option or change any browser settings).

Please try again and let me know if you still have this issue in SimBrief.

Cheers,