Game stutters/hangs every 15sec ish due to navigraph

I only purchased navigraph the other day for use in MSFS, After installing it using the latest version I noticed that whatever aircraft I use the sim has started to stutter, almost pause for a good second every 15s-45s ish.

I have attached a link to 3 videos showing this happen (towards the end of the 15sec videos)

HContent.xml (4.0 KB)

After removing the navigraph folder from the Microsoft Flight Sim 2020\Community folder and reloading the sim everything works fine. And after uninstalling and re-installing loads of different things I have certainly narrowed it down to navigraph. (it also started after I purchased it too)



Are you running Simlink? If so, does disabling Simlink remove the stutters?


I installed symlink when I first got it but later realised I didn’t need it so uninstalled it and the problem persists.

I have also now completely removed all navigraph from my system and then re-installed it and it made no change.

I am running the steam version of msfs

Just fyi I think I have found a solution of sorts. I found that if I ran the msfs executable as an administrator then it no longer had the issue, When I ran it from the normal steam desktop icon it was a stuttery mess again.

At least I can run it as admin for now… Only tested quickly on a cessna and I will do more testing and report back if I run into any more issues

Thank you for the update.


This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.