FMS Manager (Win10) always unresponsive after ~30 seconds

Hi all,

FMS Manager on my Win 10 system is giving me a lot of trouble. It used to work fine, but now it always hangs after about 30 seconds of running. It doesn’t matter what it’s doing at the time – even just launching it and waiting, it’ll be unresponsive. If I run it and then quickly start a data update, it will start and then hang, leaving behind incomplete updates.

I tried reinstalling it a few times, but I’m not sure where it keeps all of its settings. The uninstaller certainly doesn’t clean everything up. When I reinstall, the previously configured sim and add-on paths are all still there. I’d like to give it a fresh start, how can I make sure all of its settings are reset?

Is this a known issue? Couldn’t find anything about hangs/crashes/unresponsive/etc.



Hi Florian,


Please disable any Antivirus and firewall.

Please use Windows to uninstall FMS Data Manager.

If they exist, please delete folders:
c:\ProgramData\Navigraph\FMSClient and c:\Program Files (x86)\Navigraph\FMS Data Manager.

Please download and install latest FMS Data Manager .

Please let us know how you get on.


Hi Ian. Unfortunately disabling antivirus software (the built-in Windows Defender) makes no difference. I did delete the directories as suggested, which results in new settings. But even just sitting at the screen where it asks for my login and password, the FMS Updater becomes unresponsive.

Hm, I just tried by quitting all sorts of other processes that were running on my system, and now it seems to be working! I’ll troubleshoot some more, and if I can ever find out which other process caused this I’ll be sure to let you know.

hi Florian,

Glad it is working. i shall show as solved.

Happy New Year


This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.